Aseprite v1.2.34.1 and v1.3-beta13

Thanks for the information, it looks like Mojave doesn’t support this “universal” binary, I think I’ll release the Intel version of the binary on Steam, that might fix this problem. I’ll need your help later to check if that is true.

No problem! Can I send you my personal email? Just to ensure I respond quicker

Contact me at with a link to your comment, I’ll take care of the ticket.

The macOS 10.14 issue should be solved right now in Steam (updated dmg file in HB, itch and Gumroad too).

Just released a patch for the regressions:

Aseprite v1.2.32

  • Fixed regression clicking same spot with selection tools to deselect t/12491
  • Improved the detection of a single click for styluses/pens to deselect

Aseprite v1.3-beta9

  • Fixed popup menu size when multiple windows UI is disabled t/12497

Click-to-deselect works nicely even with a stylus, thank you!

Edit: And I see the right-click menus look good again even with multiple window UI enabled.

1 Like

Hello there, I’ve just found an error after I updated to the v1.3-beta9 via Steam. When I run Aseprite, the frame and Zoom indicators located usually in the bottom right of the screen aren’t visible. This doesn’t happen with the v1.2.32. I have to enter and exit Advance mode with Ctrl+F to get the indicators visible again.

(My OS is Windows 10)


Hi guys! I’m running Aseprite 1.2.32 on a M1 Mac Book Pro (BigSur), Steam edition.
I usually run the app from /Users/me/Library/Application Support/Steam/steamapps/common/Aseprite/ but now it runs the arm-64 version with the New Aseprite v1.2.32 available! notification button activated.
If I run the app from Steam, it runs the -x64 (which I desume is the M1 version) and the notification button is gone.
There is a way to start the M1 version directly from the app, bypassing Steam?
Thank you in advance!

P.S. By the way, i’m in love with Aseprite.

1 Like

Hi @pixi_bit! Actually the M1 version is the -arm64 one, and the -x64 is the Intel one. From what you said it looks like Steam executes the -x64 version from the Universal binary, it’s quite strange because Steam should just execute the binary (and not looking inside the Universal binary).

1 Like

You’re right! I’m going to fix it (there will be a new v1.3-beta10 today with other critical fix).

1 Like

Hey @dacap thanks for the instant reply! Well, this sound great for my issue.
If I can be useful, feel free to ask me any kind of test you need, I’m glad to help.

Thank you for macOS M1 chip support!!

1 Like

Hello! I’m pretty new to Asperite, and I keep seeing the New Asperite V1.2.32 is available button, but when i click on it, it brings me right here. Not exactly sure how to update to the current version, if I even should. A reply back would be awesome! Loving Asperite, by the way. Not great yet, but pixel art has now become a hobby / passion of mine and I’m so happy to have an application as good as this.

1 Like

hi rhetoric, you have to update from the website you’ve got the aseprite in the first place. that would be humble bundle, gumroad, or steam.

1 Like

Hello, thank you for the awesome work on Aseprite!
I have a small issue, even though I’ve updated Aseprite (via Humble Bundle), I still get the “New Aseprite” notification. I cannot find a way to dismiss it. Please see the picture below.

I am on an M1 macOS Monterey 12.3. I have tried updating again.


Hi @umutseven92, thanks for your kind words. About that bug, it’s highly probable that it’s related to a bug in our server. I’ll fix this ASAP and maybe in a day you will not see that message again (no need for update).

1 Like

The arm64 needs update bug is still present for me unfortunately! Also on apple silicon.

Will aseprite be released on the AppStore?

Schermata 2022-04-17 alle 11.51.24

Same here ;-] (just updated minutes ago)
Edit: No “update bug” If I run the app with “Open with Rosetta” option enabled (intel emulation).

Edit2: 8 hour later the problem is solved. Thank you! And happy easter!