Compiling Aseprite on Ubuntu with resize mode


#1

I compiled Aseprite on Ubuntu 17.04 and coudn’t resize window which I found then that it’s common issue. I compiled it at first as it is (with USE_SHARED_ALLEGRO4=ON) in CMakeCache.txt - so I installed latest version of Allegro library and set the bool to “OFF” and did it again. The result is the same. Still can’t resize it. After a few more tries with installing Allegro 4 instead of 5 and so on I had finally Aseprite maximized but that was it - no button for resizing, the issue persists. Also I noticed that now I build a lot less files than first time - like hundred less (don’t know if it should be like that). But when I downloaded trial version from official website it worked as should. No problem. So I must missed something. Any help what I did wrong? Thank you.


#2

Hi @dexxter24, actually this is a known issue when we use the official Allegro version, you have to disable the shared version of Allegro (USE_SHARED_ALLEGRO4=OFF) and use the version that is included on Aseprite repo.