Error with gumroad 1.2.35 amd64 DEB file

Hi, I went to download a newer version (1.2.35-1_amd64) from gumroad where I purchased aseprite. I’ve tried a couple of times, but each time, I’m getting an error installing the DEB file. Wonder if there’s a problem with the DEB and it needs to be re-built? Thanks for any help here!

sudo dpkg --install Aseprite_1.2.35-1_amd64.deb
(Reading database … 295221 files and directories currently installed.)
Preparing to unpack Aseprite_1.2.35-1_amd64.deb …
Unpacking aseprite (1.2.35-1) over (1.2.32-1) …
dpkg-deb (subprocess): cannot copy archive member from ‘Aseprite_1.2.35-1_amd64.deb’ to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess returned error exit status 2
dpkg: error processing archive Aseprite_1.2.35-1_amd64.deb (–install):
cannot copy extracted data for ‘./usr/share/doc/aseprite/docs/’ to ‘/usr/share/doc/aseprite/docs/’: unexpected end of file or stream

Hi @xtitus, all files should be fixed now. Gumroad was giving some problems with uploaded files but now it should work.

1 Like

Thank you! I just re-downloaded it from gumroad and it worked perfectly. :grinning: