Multi colored pixels showing up on game but not in asprite

Hello! Im new to asprite and I was wondering if anyone could help me. I made a 10x10 sprite and upped the sprite size to 75x75 when I wanted to test it, but whenever I imported my sprite it would show different colored pixels surrounding it depending on the background on the canvas. This lead me to believe it was the engine I was using So I tried remaking the sprite from scratch. this unfortunately lead to the same outcome which also made me think it was the engine but then I tried erasing the already transparent parts of my sprite and this got rid of the pixels that only seem to show up in the game Im working on. I was wondering if anyone knew what this was and how I can stop this from happening.

This is what happens when the background color is black
invisible pixels showing

here is what it looks like on a blue background

and here it is when i erased the transparent areas that were showing up wrong in game
good sprite2

You should really post .ase file with the problem. It’s hard to guess what exact problem you have among several variants.

my bad

also i found out the sprites show up bugged in the save screen in asprite as well

sorry i linked it wrong

I don’t see anything wrong with your sprite. What actions do you perform exactly for bug to appear? Could you write all the steps one by one with all the details for me to repeat the process? For example, Sprite → Sprite size… has Method of resizing which is important. And what operation in Aseprite do you use to “import” sprite?

And what do you mean as “save screen”? … Ok, I reproducted save screen problem. I resized sprite to 750x750. It indeed looks buggy.