[SOLVED] Bottom side of screen glitching on MacOS

Hello, I downloaded the trial version of Aseprite for testing on MacOS Monterey 12.0.1 but encountered this weird glitch whenever I moved my cursor. It seems to affect only the bottom part of the screen and only when I move the cursor (doesn’t happen when scrolling).
I’ve recorded a video showing what I mean:

I hope someone is able to help me :slight_smile:

Hi @bia, thanks for reporting this. I was able to reproduce it after a fresh install (deleting my preferences). I’ll take a look and check what is causing it, not sure if it’s related to Monterey or is something happening in previous versions.

Meanwhile you can try changing the scaling options from Edit > Preferences > General to these values:

  • Screen Scaling = 100%
  • UI Elements Scaling = 200%

EDIT: Created a GitHub issue related to this bug: macOS glitch flipping dirty rectangles · Issue #3032 · aseprite/aseprite · GitHub


Hello, that seems to have solved it although the interface does look very tiny now haha. Thanks for the quick response! Is the fix coming in the next public release and if so, when’s that gonna be?

The fix will be available in the next public release, given that this bug is quite critical, we’ll see if we can include other fixes and make the release sooner (maybe in a couple of weeks).

1 Like

Alright! Thanks again! Feel free to lock the thread now :slight_smile: take care!

1 Like