The index 0000 is black, not transparent

Hi, I want to use transparent ink to remove colors but the transparency color Idx-0 only fills it with black color. I set the color mode to indexed, both background and foreground colors are Idx-0, the transparent color setting is set to Idx-0, and only have one layer. I’m not sure why I can’t get the transparency again. Reinstalling didn’t work either.

This happened when I changed the background properties in preferences. I changed it to custom and toggled the default foreground/background colors. That’s when it happened, but changing them back to Idx-0 doesn’t work.