2k Monitor causing cursor lag despite scaling raised to 300% in program

I’ve recently upgraded to a 27 inch 2k monitor ( 2560x1440 ) And asesprite was lagging the first time i tried to open it, even softlocked my system for a bit.
After figuring that out, i’ve noticed the cursor is still moving slower then it should.
It was fine before i upgraded, and going back’s really not something i’d like to do…

Is there anything i can do to prevent this aside from downgrading my monitor back to 24 inch?

1 Like

Unsure, but maybe try different versions of Aseprite. As a data point, I’ve been running various builds of Aseprite on a 27" 5k display for 3+ years and have never experienced the problem you’re describing.

A shot in the dark:

Does the Aseprite window’s size affect this issue? If running Aseprite as a small window helps, then it’s possible your CPU can’t keep up with rendering Aseprite at the larger size (AFAIK, Aseprite is entirely software rendered currently, I don’t think hardware acceleration has been added yet. At least I didn’t find a github issue saying it has, and there’s no hardware acceleration option in Preferences).

If this is a rendering speed issue, try experimenting with different combinations of Screen Scaling and UI Elements Scaling in Preferences > General, it’s possible that lower scaling on UI Elements and higher scaling on the Screen will help.

the UI scaling cannot be lowered, it is at 100%
the Screen Scaling is at 300%
as for CPU, i’m genuinely sure that a Ryzen 5 3600 ( 6 core cpu ) can handle something like asesprite.

And, it doesn’t really help to run it smaller, it lags no-matter the size.