Applying palette and alpha

I am trying to apply a palette to a sprite but I have problem preserving the shadows. I created a palette, added some tones for the shadows but when I change to indexed mode I have some weird results.


With Octree:

With Table RGB 5 bits + Alpha 3 bits:

As you can see the shadows are not mapped properly to the shades at the end of the palette.
I am not sure what is happening. With some test images it seemed to support alpha when applying a palette just fine.

Anyone knows how to solve this?

Thank you

PS: I am using v1.3-rc1-x64. Tried with earlier version but still no luck.

hi, i believe the reason is the palette has more than 256 entries, so aseprite ignores everything above index 255 during conversion to indexed mode.


Oh! You are absolutely right. I didn’t know about this limitation!

1 Like

Thanks @Olga_Galvanova for the answer, I think something missing in Aseprite is a kind of warning about these bigger palettes (probably something visible in the same palette).

1 Like