Aseprite 100% zoom level very inaccurate at 4k resolution

I am making pixel art for a 4k game and every time I try to put Aseprite on a 4k monitor to see how it looks, I get very very inaccurate images. However, if I export the image and then put it on the same monitor, I get a clear, crisp image.

Here is an image which shows (from left to right) 1. What my monitor shows (very inaccurate). 2. What a screen-cap shows (inaccurate, but in different ways than 1.) and 3. what the image looks like at 200% ][]

What is going on and how do I get an accurate image on 100% zoom on a 4k? I have tested it with a direct in monitor (displays what is sent with no changes)?

Thank you!

Please don’t use lossy formats like JPG when uploading images where accuracy matters.

The shapes and colours in your 100% screenshot look correct to me (aside from the JPG artefacts xP), so if they look off in person like they do in the photo, I wonder if perhaps your monitor’s native resolution is smaller than 4k, causing it to scrap or blur some of the extra pixels?

Does the image look correct when displayed at 100% zoom outside of Aseprite? i.e. is this definitely an Aseprite problem?

One way to check if your monitor or OS settings are the problem is by viewing an image such as this 1px checkerboard dither in a program that you trust not to have scaling issues (common web browsers are usually pretty good for that!), and photographing it:
If it displays as an even grey in person and you get a clean checkerboard pattern in the photo, then your screen is probably not the problem. If you get some uneven or blurred parts, then your resolution is probably set incorrectly.

If your screen passes this dither test and if your art looks correct outside of Aseprite, then Aseprite’s or your OS’s high-DPI scaling is the likely problem. If you have some % scaling set in your OS, make sure it’s a multiple of 100% (e.g. 200%), as uneven zooms can also cause this problem.