Aseprite doesn't start on macOS


#1

I joined this site today but I’ve been using Aseprite for quite a while now. I’d downloaded it from Steam and I saw on this site you could add themes to it. I went to add a theme and followed the instructions but I did something wrong and now it won’t work at all. I’ve tried uninstalling Aseprite, I’ve even, in fact, bought it again but through the actual website, installed it, and it’s simply not working.

At every attempt to open, I get this:

I’m really hoping to fix this issue, I use Aseprite daily.


#2

Hi, I don’t know if you uninstalled the old Aseprite? Also try this… locate your .ini file and delete it (users/appdata/roaming/aseprite) then open aseprite again.
Might help?


#3

Just noticed that Dacap answered a similar question to yours recently, have a look at that thread too :slight_smile:


#4

Hiya!
Thanks for your response.
So I did actually look at that response that Dacap made, and it doesn’t quite help me, because I do have the most updated version of both the beta version of Aseprite and since I just bought the program again, it should be the absolute most updated version!

It says Aseprite-v1.1.13 on the application file and Aseprite-v1.2-beta10.

I’m just confused as to how I can remove the theme if I don’t have the capability to open the program and remove it the way I installed it.


#5

@wolliel Sorry, I didn’t @ you, hope this works.


#6

Have you found and deleted the .ini file? Once you do this, Aseprite should reset to the default theme I think.


#7

@wolliel
I’m actually not sure if I have. Sorry for my ignorance, do you know where I might find it?


#8

well, in Windows it is the path I said in my first reply to your post. If the AppData folder is not showing in your User directory it is probably hidden. So you will need to change the File View to see the Hidden folders.

I don’t know anything about Mac OS though, perhaps someone else can jump in here?
(I found this if it’s any help http://ianlunn.co.uk/articles/quickly-showhide-hidden-files-mac-os-x-mavericks/ )

And this from Aseprite/faq:
Mac OS X Specific
Where is .asepriterc on Mac OS X?

It’s in your home directory (⇧⌘+H) as a hidden file.

good luck


#9

I am doing the same thing
I am OS X 10.11, but I can not start just beta
Normal can be activated


#10

I’m sorry, I don’t know MAC OS at all. Hopefully someone else will see this and be able to help you further.


#11

Hi @Catbat and @111, it looks like the theme that you’re using is crashing Aseprite.

  1. I would like to know the name of the theme and where I can get it (so I can fix this for a future version)
  2. You can reset the preferences following these steps (please check the macOS section).

I hope it works!


#12

@111 I wish you the best of luck!

@wolliel Don’t apologize, you have helped me tremendously and I appreciate it so much, sorry if I sounded snippy any time before, but thank you again!

@dacap Hiya, the theme was the one at this link:
https://tungkradle.github.io/aseprite-than/

I’ll follow those steps and tell you what happens, thank you so much.


#13

@CatBat no worries. btw I just downloaded that theme and it works fine for me on Windows 10.


#14

@wolliel I’m wary of trying to install it again, because I’m afraid I’ll mess it up, but glad it works for you!

@dacap It’s worked! I can now open the Aseprite application, I can’t open the Beta version, but I’m happy being able to use the program again. Thanks so much.


#15

My Aseprite crashed on startup as well. For me deleting the aseprite.ini file didn’t work, but deleting the whole folder (~/Library/Application Support/Aseprite) worked! Thank you for indirectly helping me!