Aseprite file format not recognised on Linux Pop! OS

Hi, I installed Aseprite via Steam on my Pop! OS (v 22.04) machine and ran into this issue. Since Pop is Ubuntu based I assumed it would work just the same, however, I am new to Linux so perhaps I was mistaken.

My problem is that the .aseprite/.ase format is not recognised and is categorised instead as “application/octet-stream”. There is no option to open the Aseprite file format with Aseprite unless changing the Aseprite.desktop file to contain a direct shortcut to the executable. However, this still doesn’t fix the issue with Aseprite format recognition as this merely changes the default app for “application/octet-stream” files to Aseprite. It also means there is no Aseprite file icon.

I have included two screenshots; The first shows what the files look like in the Files manager (after I have changed the Exec path so that Aseprite appears as a choice when selecting an application to open the file with), and the second shows the .desktop file (the blank space in the path is where my username is).

The original Exec path was ‘steam steam://rungameid/431730’

Aseprite version: v1.2.39-x64 & v1.3-beta20-x64

I appreciate any help. Thanks.


What you are trying to do is called adding custom mime types. Check out the following resources:

(This one shows how to add multiple file extensions to one mime type.)


Actually we have a mime.xml for .ase and .aseprite files: aseprite/aseprite.xml at main · aseprite/aseprite · GitHub

But we’re not distributing it with the .deb packages, maybe we could start doing so. Where should be this file installed (e.g. on Debian/Ubuntu-like distros)?


Many thanks for pointing me in the right direction, xtendera!

1 Like

Thanks, dacap. I used the file you provided and think I am on the right track now.
I have managed to get the Aseprite format to be recognised as “Aseprite Pixel Art” files and have set the default app for these files to Aseprite. However, I am still having trouble getting the file icon to appear, so I will fiddle around some more and update this post with the full solution after I have everything worked out.


They are installed to /usr/share/mime/packages/.
Then the mime db has to be updated using
sudo update-mime-database /usr/share/mime

1 Like

I finally got everything working! I was running in circles there for a while but I managed to narrow it down to a few steps.

  • Create an aseprite.xml file in /usr/share/mime/packages/ based on the one linked by dacap (sudo vi /usr/share/mime/packages/aseprite.xml, paste the file contents and enter :x)

  • In the Aseprite.desktop file add the line MimeType=image/bmp;image/gif;image/jpeg;image/png;image/x-pcx;image/x-tga;image/;video/x-flic;image/webp;image/x-aseprite;

  • Move the icon to the Pop folder instead of the hicolor folder and change its name to aseprite.svg. I chose the icon called doc.ico: sudo cp ~/.local/share/Steam/steamapps/common/Aseprite/data/icons/doc.ico /usr/share/icons/Pop/scalable/mimetypes/aseprite.svg
    If you call the icon something else then make sure you also edit the .xml file so that the icon name matches.

  • Update the desktop and mime databases, and the icon caches:
    sudo update-desktop-database ~/.local/share/applications/
    sudo update-mime-database /usr/share/mime/
    sudo update-icon-caches /usr/share/icons/*

Changing the .desktop file to contain a direct shortcut to the executable as seen in my original post is not necessary since you no longer need to select Aseprite from the ‘Select Application’ window, but for me it makes the program launch instantaneously rather than taking a few seconds and perhaps there are some other benefits.

Thanks again to @xtendera and @dacap for your help.

1 Like

Also, I downloaded the trial version of Aseprite directly from the website and the steps for that version are the same, with the exception that you don’t need to touch the .desktop file at all. The file icon is located at /usr/share/aseprite/data/icons/doc.ico.

1 Like