Aseprite Not Launching on Steam

Apparently Aseprite stopped working and Not Launching and so far tried…
Restarting PC
Uninstalling then Reinstalling
Shutting Down AntiVirus
Use Launch Options to Generate Certain Files Recommended in the Troubleshoot Guides
Switching Between Software Versions

I’m Using Steam Version

Open the Task Manager and check if the Aseprite exe is called when you try to open it. Perhaps it opens for a few moments then it crashes.


Try opening a file instead of the app. Maybe the shortcut got messed up when you reinstalled.

If all else fails, go to the Aseprite.exe location and double click on it manually. If you tried all the troubleshooting steps, there should be a .txt generated when you tried running it in debug mode. Open it and it might have some hints about why it’s not opening (you could also e-mail it to the devs).

If you don’t care for your preferences or saved sessions (recovered files), you could

  1. Go to Windows → Run → “%appdata%” (no quotes) and hit Enter.
  2. Rename the Aseprite folder.
  3. Try to reinstall via Steam.
  4. Try opening Aseprite.

Yeah Its not even popping up in task manager and also tried what you recommended and nothing
also i did try to make debug files and stuff like that but nothing happens

Sorry to hear that. If it’s not even creating the debug txt, there isn’t much I can think of that might work. Just to be clear, these are the steps to enable debug mode on the Steam version: Aseprite - Docs - Debug

If there was something wrong with your Steam account (like not properly logged in or connected), Aseprite’s Steam version is DRM free, so it should always run, at least on Windows (I think).

If you have a tablet you could try unplugging it, and setting the .ini file in the preferences like instructed in the troubleshooting guide to disable it.

I’d send an e-mail to support describing all the steps you followed or wait to see if someone knows what else to try. If you’re desperate, you could try doing a deep uninstall of Aseprite, though I would only recommend this if you knew something about Windows and computers. At any rate, try it at your own risk.

Some tools would be Revo Uninstaller, Geek Uninstaller or this one.

I launch through steam and have run into an issue myself that causes this to happen for me that is related to my Huion tablet driver aplication, I’m not sure exactly what causes it, however, i have to close and relaunch the software that controls my drawing tablet, steam, and aseprite to get it to launch at all.

Ok I do Have My Wacom Cintiq 13 HD Plugged in so I’ll have to try something with the drivers

Ok Yeah Nothing is Working Sadly

Ok So an Update is I was Able to Get the Debug to work and it writes nothing in the text file nor does wintab work for disabling.

Hi @DJWolf3, just in case, did you try disabling wintab?

Here the steps to do it on Steam.

Thanks for the Suggestion but I already have tried that
sadly when disabling wintab it does nothing
when using debug option it doesn’t write any text in the log files
when reinstalling nothing happens nor does deleting files from the directories that the software uses does nothing as well
restarting PC does nothing
software cant be seen in task manager
running as administrator or compatability mode does nothing
disabling my wacom tablet software does nothing nor does disabling wacom drivers does nothing as well

LOL So many things but Not all work