Aseprite v1.2.18

Hi asepriters! We hope you are taking care of yourself in these hard moments we all are living :microbe: :soap: :roll_of_toilet_paper: Today we are releasing Aseprite v1.2.18 with important fixes and a little new feature which you can start playing with :pen: :eyes:

How to update Aseprite?

11 Likes

This is an amazing update! I am super excited about the pen pressure and script extension new features! You are the best! :smiley:

2 Likes

I am so so happy pressure sensitivity has finally made it to Aseprite!! And the gradient feature between 2 colors, with dithering options, is a sweet and unexpected bonus :open_mouth:

1 Like

hi david, it’s always a good day when there’s new aseprite update!

when testing pressure sensitivity feature i’ve encountered this strange behaviour:
_dither-problam
— pressure works fine for size
— however it is inverted for dither patterns (less pressure = fg, more pressure = bg mask) and leaves me with dot at the end of the stroke
— for no dither pressure doesn’t work at all if background color is mask. if background is another color (with alpha=1 at least) it works, but gradient is inverted again.

i know i can swap fg and bg with ‘x’ key, which mitigates the issue for dither option, but i’m a bit confused if it was intended this way or something is wrong on my side. i would expect less pressure = less alpha with gradient from 0 to max value (having to set alpha to 1 and switch fg and bg seems overcomplicated).

also when making fast strokes with no dither the stroke isn’t smooth, while with dither it is:
_fast-strokes
i’m on win7 with intuos3 tablet.
to be sure i restarted windows, tried again several times and checked in photoshop if tablet works as usual.

2 Likes

Hi @Olga_Galvanova! yes, the fg/bg are inverted we’re going to fix that (reported by other user via twitter). The brush size also should make more sense if indicates the max size (and the dynamics will show min/max size, but the max size will be the same as the brush size, right now brush size=min size which doesn’t make too much sense for most cases). Also colors with opacity as you see will not work as expected, a long standing bug that now it’s more visible with dynamics, to be fixed for v1.2.19.

2 Likes


oh help me please,how can I FIX IT !
It’s better to be able to recover the files as before!

Hey! First of all, I want to say that I love workign with Aseprite on my macbook :slight_smile:! Unfortunately since this update, a lot of bugs came into play. The slice option is pretty much unusable now, as I can’t make new slices. Next to that there are drawing errors :frowning: hope you can look into this

EDIT: Hmm, it seemed that my file was corrupt. There were some slices in there of over a BILLION pixels wide, which also caused the drawing errors. For me the issue is fixed now, but I’m not sure if it might happen again in the future of other users

EDIT 2: It happened again. Every time I open the document, about 8 slices become 1634467863 pixels wide and high. I’m not sure why this random number, but maybe it’s useful for you :slight_smile:

Hi @R18OUND, please check if your file is available in the “Recover Files” option in the “Home” tab:

image

Welcome @Ronald-Baars, please contact us at support@aseprite.org privately with your .aseprite file so we can check what is wrong with it.

HI there,My software version is v1.1.12,I did not upgrade it.
therefore,I don’t have this option.
Thanks a lot !

Hi,
I’m trying to use the new “pressure” feature that I’ve been waiting for so long, but it doesn’t seem to work.
I’m using a Wacom Cintiq 13 on Windows 10 and all I did was selecting the option “pressure” and nothing happens. Am I missing previous steps to set this up properly or I’m just working with incompatible tools?

Oh, and of course I tried restarting my PC and everything.

Thank you!

1 Like

I have a Cintiq 13HD and it works for me. Make sure the settings are right.

image

3 Likes

Just in case we’ve fixed a problem were tablets cannot be detected. @juanitomedina you can contact us at support@aseprite.org in case that you want to give a try to a preview of v1.2.19 with the fix.

2 Likes

Oh, Thank you, I didn’t realise there were more setting options there. Anyway, now it seems to work fine.

how can i update Asesprite when i download it on the website?

Hi @uwu_shini, check this link: https://www.aseprite.org/faq/#how-do-i-update-my-current-version

thanks, but how can i do it when i have only download it on the website with out any account on any different web?

sorry i’ m a bit confused ._.

@uwu_shini please contact us at support@aseprite.org using the email address you have used in the purchase process and we’ll be able to send you the link to update Aseprite.

I just buy the latest version , but It cannot run up on my machine.OS windows 10.

but the old version v.1.1.09 can work well on my machine.

so what next can I do to resolve this problem?

Just in case for the record (if someone have the same issue), the problem of @davidyj was that in the AppData folder (%APPDATA%) there were some files of an old installation:

%APPDATA%\Aseprite\data\widgets\...
%APPDATA%\Aseprite\data\gui.xml
etc.

Generally this data folder should not be in the AppData folder (it can be there in case someone wants to do some kind of specific customization to widgets or gui.xml file, but it’s too internal, so you should know what you are doing in these cases).