Aseprite v1.2.19.2

Hello there asepriters! :wave: A minor release today with some critical bug fixes and some tweaks :wrench:

  • Aseprite v1.2.19.2:
    • Fixed Simple Ink on Indexed mode when painting with the transparent index (it must behave like the Eraser)
  • Aseprite v1.2.19.1 for Windows:
    • Windows: Added Edit > Preferences > Tablet options to easily switch between Windows 8/10 Pointer API and Wintab (the Pointer API is used anyway if Wintab cannot be initialized or loaded by default)
    • Windows: Fixed some regressions handling events from some tablets/drivers
  • Changes to Dynamics/Pressure settings:
    • Now Brush Size is the maximum point of pressure (request)
    • Paint with Foreground Color when sensor is at its maximum value, and with Background Color when it’s at its minimum (t/5779)
  • Improve performance drawing selection boundaries
  • New hept32 palette by ENDESGA
  • Fixed some issues with some Wacom tablets on Windows
  • Fixed some critical problems in the new compressed TGA encoder
  • Fixed shading ink for RGBA and grayscale modes in some special cases
  • Fixed some crashes using shading ink and switching between sprites with different palettes
  • Fixed saving layer user data in backup sessions in case of crash #2373
  • Fixed rendering of RTL text in text entries, still requires better text editing capabilities #2355
  • Fixed Alt+click on timeline icons for selected layers #2222
  • Added missing Dialog onchange and onrelease events and expanded Dialog:modify{} function #2359 (thanks to @grauw)
  • Other fixes api#29 #2388

How to update Aseprite?

11 Likes

Omg, great job! Thank you so much for you and everyone working on this project!

2 Likes

Good work!

1 Like

I can no longer draw freehand with my Huion Q11K tablet in 1.2.19, while 1.2.18 was fine. It just draws a single pixel and then stops. Not sure why that is, hopefully it gets fixed by the next release though.

Try disabling the wintab32 library and see if that helps.

1 Like

Oh wow, finally, we have onchange event on widgets! This plus the extra functionality for Dialog:modify is game-changing, we should now be able to make responsive dialogs! :open_mouth:

1 Like

:blush: that’s right (actually the Dialog:modify{} was added in v1.2.18)

2 Likes

I’ve had the same problem with another piece of software. I found that updating my drivers worked. If that doesn’t work, I’ve even had it work when I installed older drivers…

I use a deco pro m and I am having problems with the new v1.2.19. When I try to use my tablet, the aseprite crashes. Previous version worked great. This is a link to a video of me trying to use my tablet: https://codingburgas-my.sharepoint.com/:v:/g/personal/mssevov18_codingburgas_bg/ETA8JqI3tt1Eo8ZACd5qK-oBIhnCCA4w4P7XPLm8_sAx7Q?e=QHEdHF

@Dom_Foxley @Martin4ata contact me at support@aseprite.org with the operating system and version that you are using

1 Like

Thanks for the fast reply :slight_smile:

I am using the steam version of Aseprite. Is it possible to rollback to 1.2.18? I tried and all I saw was: 1.2.8, 1.2.13(doesn’t work) and 1.2.beta2.

This new update made my Huion Kanvas tablet stop to work on Aseprite.

@jamesfoxbr please follow the conversation in one thread

@Martin4ata try to restart Steam, I’ve rollback the update on Steam

The brush size pressure options are way more intuitive now, thank you!
I like that it’s still possible to set the “minimum” size larger than the brush size, allowing for an inverse pressure curve. This is rarely useful, but it’s cool to have the option.

I also like the addition of an option to invert FG/BG for gradients. It’s hard to spot that it can be toggled though, perhaps an “Inverse” checkbox instead might be easier to notice, even if it’s not as immediately informative?

It looks like pen pressure gradients with one of the colours being transparent don’t work properly. The stroke takes on the non-transparent colour instead of fading gently between transparent and the other colour. I’d sort of expect this on Indexed Mode (but even then, I’d expect it to lay down the nearest palette option instead), but it’s like this in RGB Mode too.

Edit: Right after I finished playing around, Steam downgraded me back to 1.2.18 with a 4.9MB “update” what the heck D:

@eishiya restart Steam and you should get v1.2.19 again, I just rolled back to v1.2.18 because thought about some problems with tablets, but it looks like disabling wintab fixed them.

Aseprite v1.2.19 should be handling tablet events in a better way than v1.2.18, but there is a “problem” with XP and Huion tablets (and maybe others) where events are reported through the wintab API and the pointers win8 API, Windows is quite a mess in this aspect, so disabling wintab for these tablets make Aseprite works.

Maybe in the future we could detect if these events are duplicated and disabling the wintab automatically.

About alpha gradients, it’s planned, but for future versions.

2 Likes

That did it, thanks! For anyone else having the issue, uncheck wintab32 and Apply, then restart Aseprite. It won’t fix it until a restart.

1 Like

I started having an issue with the Lasso Too using my Wacom Intuos Pro Medium.

Every time I click to start drawing the shape with the Lasso, it automatically selects the entire grid square area, the behavior of double clicking. If I try using the mouse it works how it is supposed to.

Any option I can simply turn off this behavior real quick?

@essecorrea you can disable the double-click behavior unchecking Edit > Selection > Select a grid tile with double-click, I’ll check if I can reproduce it on Windows:
image

I’ve just released Aseprite v1.2.19.1 having the same behavior than v1.2.18 + some extra options in Edit > Preferences > Tablet.

2 Likes