Aseprite v1.2.35 and v1.3-beta16

Hi there asepriters! :wave: :art: Today we’re releasing a new Aseprite version with several bug fixes and performance improvements. From now on we’ll be focused in v1.3.0 to merge both versions in one and “finish” the Tilemap feature with some extra features :magic_wand:

Aseprite v1.2.35

  • Extensions with keyboard shortcuts is now possible #1403 #3239
  • Performance improvement in color selectors #960
  • Added button to refresh the current folder in File > Open #232 (thanks to @Enfyve)
  • Fixed mouse wheel direction to change brush size when we use Ctrl+mouse wheel: mouse wheel up increase the brush size, and mouse wheel down decrease it #2364 #2896 (thanks to @TehThanos)
  • Fixed clicking on empty palette space #2776 (thanks to @ruerob)
  • Fixed error messages moving/copying multiple cels from the Timeline when the Cel (or Layer) Properties dialog is open #3278 t/14170
  • Fixed performance issues closing the Undo History window #3281
  • Fixed issue deleting/modifying and undoing Reference Layers #3264
  • Windows: Fixed crash deleting folders while navigating folders #2950 (thanks to @sainthkh)
  • Keep plugin preferences when re-installing an extension #3259
  • Improved selecting words w/double-clicking #3229
  • Added “Show: Menu Name” commands so the user can customize Alt+letter shortcuts to open top level menus #3239
  • Fixed painting extra straight line using Ctrl+Shift w/Pencil tool #3196
  • Fixed several bugs related to decoding utf-8 strings (could crash
    the program showing truncated Unicode filenames in the file dialog) #3260
  • Removed tag range adjust when exporting sprite sheets #3210
  • Fixed wrong json export with linked, trimmed cels #2600
  • Run console of errors in background #3227
  • Linux: Fix delay pasting text from Aseprite to gedit clip#57
  • Linux: Dropped support for Ubuntu 16.04. Ubuntu 18.04 is the minimum now
  • Lua: Added possibility to set Cel.frame property to move a cel quickly to other frame
  • Lua: Don’t show tooltip when a new frame/layer is created from a script transaction
  • Lua: Fixed crash when a Lua error happens in a Dialog onclose #3237
  • Lua: Dialog() returns nil if there is no UI available
  • Lua: Fixed Color HSL Constructor

Aseprite v1.3-beta15

  • Fixed bug copying cels in the Timeline when the Cel Properties dialog was open #3278 t/14170
  • Fixed painting issues #3242

Aseprite v1.3-beta16

  • Fixed regression selecting tiles from the color bar #3357
  • Fixed issue with dark theme: refresh button in file dialog didn’t appear #3355

How to update Aseprite

8 Likes

Thank you! This one always made my brain hurt XD

2 Likes

I wonder, how are conflicts resolved between keyboard shortcuts from extensions and the ones set by the user?

Those of the user have more priority. These are the steps when Aseprite starts/an extension is added:

  1. Load the default shortcuts
  2. Load shortcuts from extensions
  3. Load shortcuts from user preferences

Each “load” means assigning and overwriting previous shortcuts. The only problem that might not be solved yet is what happens if two extensions define the same shortcuts. A missing option that didn’t make the release was a checkbox to disable extension shortcuts (and maybe in the future some information about the source of each shortcuts in the Keyboard Shortcuts dialog might be useful).

Anyway it’s highly probable that something will not work, so any kind of feedback is really appreciated.

4 Likes

That’s a sensible approach, thanks for clarifying!

2 Likes

Love your work,
Just a quick feedback on 1.2.35 on Mac : default shortcut for changing brush size doesn’t work…(at least with me)
even if I try to change the shortcut, it seems to use others shortcut first:

-default command is CMD+ mouse wheel, here it show the move tool(cmd), and scroll up and down while I use the wheel
-If I try to change to CMD+ CTR + mouse wheel, it will target one of the default tool assigned to either to Cmd or Ctrl…

This last update on the beta channel on Steam made everything super slow to make. For everything i do, i have to wait for it to unfreeze (like its processing a lot of things in a turn-based game). I have to stop working because of that.

Can i just have the previous beta version? Until things get fixed.

Hi there! The default shortcut is Ctrl+mouse wheel on macOS included. Is that one that is not working? Are you using the mouse wheel or a trackpad gesture?

Just in case, could you please try unchecking this option Edit > Preferences > Experimental > Use shaders for color selectors

Yes it’s the default one, but it’s true that by default Mac users don’t have “wheels” on mouses, it’s the Magic Mouse, so I guess it’s considered as a trackpad gesture

In that case you can give a try checking the Edit > Keyboard Shortcuts > Mouse Wheel > Zoom sliding two fingers up or down option. I think it should work. I’ll check later if there is a way to detect the trackpad vs magic mouse.

1 Like

And it works as a charm with this… okay I didn’t find it obvious when reading the “zoom sliding two finger” option, but now we discuss of wheels and trackpad, I understand better :slight_smile:

1 Like

That fixed it.

1 Like

Interesting, we are starting to test shaders to see its performance so it was something that could happen. Even more probably we’ll completely change how color selectors are displayed in the future but glad to know that the option worked for your.