Aseprite v1.3-beta1

Just switched to the beta and have to say I love it so far. Going to take a bit to get used to it, but I’m much happier with this over switching between aseprite and the other program I had previously used for tiles!
It has some kinks - obviously, what with it being a beta - but so far nothing that makes it unusable, as far as I have seen ^^

1 Like

on steam has not updated to a new version

Make sure you’ve opted into the beta on Steam:

(There’s a link to detailed video instructions in the OP, if you need that.)


i alredy know that but still making such inputing the operations is not the best, especiallyin the nightswhen your brain is half functioning, in any way i think being able to create canvas by tiles inted of having to input the right pixels would be GREAT

1 Like

I’m testing 1.3 beta on steam and I’m loving it. Thank you very much! ^^

1 Like

I also found out that if I have my Tilemap layer selected and some other layer (or layers) overlap it with some blending (or without) then Eyedropper tool does not allow to pick tiles in those areas they intersect. While this is OK for color picking, it’s not so OK for tiles picking.

Also I suggest to use another set of mouse cursors for Tile drawing/picking operations, like maybe add small square to tool cursor. This will help to easily distinguish between Tiles mode and Palette mode, which is essential. And there’s no real need for one pixel precision in Tiles mode cursors.


I’ve been using it for commercial work since release, pretty much every day - so far so good (touching wood)

1 Like

Do I report the bugs here or in the bug section for beta1.3 ?

one problem is the skew the left right direction ok but up down seem get confuse as the GIF show :

2021-05-31 20-36-28

Amazing update! :confetti_ball: :confetti_ball: I have been messing with it for the past few days. For now I used your tileset export script and just commented out the JSON writing part as I don’t need that for the moment.

The detached preview window is a HUGE upgrade as I can now preview my animation on my CRT :smiley:

I have a question though – I accidentally created some tilemap layers with “new tileset” instead of my existing one, then deleted the layers. Those empty tilesets still exist because I see them being exported with the script and they are listed as tilesets to associate with new tilemap layers. Is there a way to delete these orphaned tilesets yet, or it’s just not exposed to the UI yet?

1 Like

this is not a new bug, it happens when you rotate things too, is just that the preview on the transformation gets confused

I think its a bug, you can’t make same result if you put a square. try do one for skewing right and left(H),
and one for up and down (V).
you can’t match it. other software can. and I think because is missing the vertical for skewing.
that’s why doing skewing in horizontal seem fine but in Vertical not.

this will be more readable specially the missing skew “V” or “Y”.

1 Like

There is no UI to manager tilesets, anyway I guess that these kind of tilesets that are not associated with tilemaps should be removed automatically. Taking note about these two issues (anyway the tileset management is planned).

Yes, we’ve used Rotation angle and Horizontal skew angle, but the fields are too confusing to handle a vertical skewing manually/by text fields. So we’ll try to add the vertical skew angle too in the fields.


Today we’ve released Aseprite v1.3-beta2 which should have this octree with alpha thanks to @Gasparoken. From now on we’ll use the octree quantization by default.


YAY, great job guys were can i see the chancelog of 1.3beta2?


Ethan, only click on the link above, in the Dacap’s comment :wink: .
Tnx guys! Nice work.

1 Like

hey tool part is being butechred

i alredy tested other themes

1 Like

Where is this beta placed on github? :slight_smile: I’d like to tweak it a bit, but can’t find the branch for it.

Hi there @Kruell, the beta version 1.3 is still not available on GitHub but we’ll publish it after some weeks.

Is the global user data accessible from a lua script?