Blue dot that can't be removed

#1

idk if this one’s a bug or not (seems like it is)…

so earlier I used a rectangle marquee tool, the suddenly this pesky blue dot (this blue dot appears on the top of all layer) appears outta nowhere. I tried disabling all layers… using eraser tool… even reloading the file… but no avail. This dot just won’t disappear no matter what I do :cry:

but the weird part is, the dot would disappear when I export it into PNG (but still persist if I save as a new ase./aseprite. file. Ended up copying the layers into a new file, and save over the old, corrupted-with-a-blue-dot file…

I’m just afraid it’ll happen again with another file… :confused:

0 Likes

#2

*other image because I can’t post multiple image…

0 Likes

#3

0 Likes

#4

Would you be alright with uploading the .ase file?

0 Likes

#5

…I’m sorry, I already deleted the broken ase. file earlier… :cry: :

I wonder if there’s someone in this forum that got the same problem?

0 Likes

#6

Then I’m not sure. However, I do notice that the slice tool icon is showing on the right, which might mean it’s a slice dot. But I think they usually show up thinner so not sure.

1 Like

#7

My bet is on 1x1 pixel slice. It can look like a solid dot when Aseprite’s Screen Scaling (instead of UI Scaling) is set to 200%.

OP, next time you see this, zoom in on it and right click inside it with the slice tool selected. This should let you delete the slice.

0 Likes

#8

I’m facing exactly the same “problem”. A blue dot appears on the upper left corner… I tried the slice-thingy that @vegeta897 mentioned but it didn’t work. 00%20PM

I also tried to modify the grid settings and nothing happened, it’s always there.
At the beginning I thought it was something related to the theme (than theme) I’m using for Aseprite.

It’s not the end of the world of course, but it’s really annoying.

0 Likes

#9

I was able to reproduce the look by clicking with the slice tool above the top left corner of my canvas, i.e. making a 1x1 px slice that’s outside the canvas.

I could not find a way to delete this slice since it’s off-canvas. It can, however, be hidden: View > Show > uncheck Slices.

So we can make slices off-canvas, but not delete slices off-canvas. One or the other of those is probably a bug that needs fixing xP

1 Like