[BUG] [Minor] Drag and Dropping Files No Longer Functions 1.2.27 x64

Unfortunately, this comes at a time when I’ve also done a complete windows 10 reinstallation due to a hardware malfunction so I cannot 100% this as an Aseprite only bug: It seems I can no longer drag files from Windows Explorer into Aseprite as I was previously able to do before this newest edition of Aseprite was released.

I did a look through the options but didn’t see anything in specific that would toggle that, and I’ve disabled any themes I was using in Aseprite in case that was causing an issue.

The cursor indicating that I am dragging something into Aseprite does appear, so it does seem to be acknowledging that I’m trying to drop a file in, but it just doesn’t load anything or bring up a prompt. Minor bug, but thought it’d be important to report since it may affect speed productivity.

Thank you for your time and your continued work on Aseprite!

Hi @Elizabeth_Ramirez, I’m testing here and it’s working. Just in case, are you running Aseprite with your user or as an administrator? Sometimes if a process is executed with a different user then files cannot be drag-and-drop between File Explorer and Aseprite (or other apps).

Thank you for the quick response!

I’m running this via an admin account which was also the installer of the program.
I tried a few different things and unfortunately, they didn’t seem to help.

  • Removed all addons/extensions/plugins from Aseprite.

  • Remove the folder in steamapps/common/aseprite to clear the old preferences.

  • Uninstalled Aseprite, Reinstalled after clean up.

  • Set Asperite specifically to run as administrator

  • Set Steam to run specifically as administrator

  • Downgraded to the previous version and upgraded to the beta versions of Aseprite.
    The last one tells me that it does seem to be some kind of conflict that’s affecting Aseprite across the board and not just the newest version. There are three outside influences I can think of that have changed since this worked:

  • I upgraded to Windows 10 Professional from Home.

  • I have a BitLocker drive for my professional work. I am not pulling the images from that drive nor do i have Aseprite installed on it, so I don’t believe that’s the issue.

  • Having swapped from a local account to an email work account login for windows. It is the same account I used to install Aseprite and has admin privileges.

I did create a new local account with admin privileges to try it on there and the problem persists.

EDIT: I would also like to add that other programs I have installed via this account still retain their drag and drop abilities.

As far as I know the issue can happen if Asprite is executed as an admin (or as a different user than the one used to run the File Explorer). Basically the user logged in (the one that started the File Explorer) and the user that starts Aseprite must be the same.

Did you try closing Aseprite and double-click a .aseprite file feom the File Explorer to see what happens? Can you drop files in the opened Aseprite?

1 Like

That fixed it!
I did as you requested and set up a .aseprite to double click. It worked and opened Aseprite. Upon doing that, it now accepts drag and drops into it from the other supported file formats! Closed the application and reopened and it still functions properly.
Fixed the issue, thank you very much for the help!

1 Like