Cannot update to 1.2.3 via Humble Bundle (also to 1.3.4)

Hello, apologies if this has been posted before, but I cannot update to 1.2.3 via Humble Bundle. I know HB takes a while sometimes, but this isn’t that; it is the correct version, but when I click Download, it just takes me to an error page with the URL that says An error occurred while processing your request. This has been happening for days now.
Can the devs please take a look? Thank you!

Hi @umutseven92, sorry about this. Could you please try doing a Refresh or Ctrl+F5 / Ctrl+R in the Humble Bundle Library and try to download it again?

1 Like

Hi @dacap, the download worked now without a need to refresh, thank you very much!


Hello @dacap, apologies for the bump, but having the same problem again, this time with version 1.3.4. Exact same error.

Nevermind, I give up. It’s been more than a week since 1.3.4 landed in Humble Bundle and the download still does not work. I ended up downloading it from Steam, since I had a Steam key from the HB purchase.

@umutseven92 did you try Ctrl+R in your Humble Bundle library to refresh the whole page? it’s a common problem in the Humble Bundle library (not sure if they cache something but the new version sometimes appears only when you refresh with Ctrl+R).