Can't double click .ase files to open them

As per title, double clicking .ase files doesn’t open them in Aseprite as expected - the Aseprite window flashes up then instantly closes.

The same thing happens if I have Aseprite open already, it doesn’t load into the already open instance, it attempts to open a new one which instantly closes as described above.

I’ve associated .ase files with the new executable and am using the latest source from Github.
Title bar shows: v1.2.21-dev.

I saw something similar mentioned in posts from 2019 but couldn’t find anything else so thought I’d post and see if it was something I am missing or whether it’s a bug / issue that has reoccurred.


Anyone have any ideas what the issue might be with this behavior?

Tried running with -debug flag but no log file is created.

Does nobody else have this issue, or have any suggestions?

Hi @rIKmAN, please check this post:

Anyway I’m not sure why the instance is closed immediately :thinking:

Hi @dacap, thank you for the reply - much appreciated!

EDIT #1:
Edited my previous reply as I tried the registry edit from the post you linked since writing it.

Running it fixed the issue and I am now able to double click .ase and .aseprite files to open them up in Aseprite! Awesome! :slight_smile:

However each file still opens up a new instance of Aseprite, which is what the registry file was supposed to fix (rather than my issue) - so that’s a strange / happy coincidence!

So I went through my entire registry and deleted all keys related to aseprite - there were quite a few for older versions too.

After doing this, rebooting and running the .reg file as per the link you posted, everything is working fine and I can now open files by double clicking them and all files now open in the same running instance of aseprite in a new tab!

Thanks again for that link - lifesaver! :slight_smile: