Can't Export Spritesheet By Row

Hi, I’m still pretty new to spriting/using aseprite, and I was having some issues with the the “By Rows” feature while exporting a spritesheet. I’m not sure if this is due to a bug or a mistake on my part.

The issue is I would like to export one row for each tag, but in the preview and exported png, there is only one row.

Here is the setup for my animation and the preview with “By Rows” selected:

If this is just a mistake in my understanding of spritesheet exporting, I’d love to know the correct way to do it/alternate methods. My goal is simply to get each animation on a different row. Thanks in advance!

Environment Details

  • Aesprite version 1.2.25
  • MacOS Catalina version 10.15

It’s working as intended. “By Row” just means the sprites will be arranged in rows, going to a new row when the max width (if one is set) is reached. It does not care about tags.

There is no built-in way to get one tag per row (as the goal of spritesheets is generally to pack things tightly, not prettily xP but such a feature would be nice to have), but you could turn each tag into a spritesheet separately, and then put those together. If you number them appropriately, you could even export each tag By Rows, load the resulting spritesheets in as animation frames, and export the result By Columns and you’ll get what you want without having to arrange them manually.

I was hecka wrong~ Make sure you have Split Tags checked and it should work.

Thanks for your reply! I am a bit confused though why the description for By Rows is “Create one row for each layer or tag” if that’s not what it does? Was this feature removed at some point?

Either way, setting a max width gets me what I wanted, thanks! :smile:

Oh whoops I was thinking of something else like an idiot. I’d forgotten my recent files were all a single tag :'D

Have you checked whether you have “Split Tags” checked in the Sprite section? That seems to work. Without this on, it treats all the tags as one, resulting in the behaviour you described.

Oh hey, that works perfectly! Thanks a ton!!