Can't pick colors when using brushes

Hey everyone!,

I’m having some trouble with the color picker, it won’t change when picking colors while using different brushes. Also, theres sometimes a problem with the ‘Ctrl + left click’ shortcut when selecting a layer, it will sometimes duplicate itself or won’t select anything (selection it’s not hidden).

Thanks in advance.

welcome, Mancubus_P!
i don’t know about the colour picker issue, can you provide screenshot/capture of what you’re doing with the brush settings? please include aseprite version you’re using and system info as well, it’s useful for developers.
just to be sure, you don’t have color picker set up to pick: color + sample: current layer?

the issue with ctrl+left click is following: when the layer is selected in timeline (it has yellow border around its name) ctrl+left click won’t make the selection. i hope this will be changed one day. anyway, hit esc to deselect it (or click on different layer or click outside the sprite boundaries when using pencil tool).
as for duplication, it is done by ctrl+left click and drag, so that might be the reason it duplicates itself.

Ok, I think that was the reason (current layer on color picker), if I found otherwise, I’ll be sure to inform!.
Thank you so much :sweat_smile: ! .


1 Like

Ok so It’s happening again!. I thought it was a “current layer” issue, but it wasn’t at all!. Now I’m working on my macbook pro macOS HighSierra 10.13.6, (last time it was on my Windows 10 PC). My Aseprite is v1.2.25. COlorPickerIssue

What should I do?.


alright, that’s interesting. never happened to me before.

so… i played around with settings of brushes and i must say it behaves much more unpredictably than i thought. i’ve tried different brush settings, different save settings and sometimes i got really weird results like painting with white when mask was actually selected, while white wasn’t an alpha colour (or even present in palette) and the sprite wasn’t in index mode anyway. it’s really strange and now i question my understanding of saving brushes and the reality itself 8O

however, i managed to recreate your issue and it seems like this happens because you have a colour stored with your brush and you try to re-select the colour you already have set as foreground colour. when you ctrl+click and pick up different colour, the brush should start to accept input from colour picker.


Hi @Mancubus_P, I wasn’t able to reproduce this problem. Did you save your brush? in that case can you send us your user.aseprite-brushes file that is in your preferences folder?

I think that if we configure a brush to save the “Foreground Color” the eyedropper should still work (the foreground color will be changed if we re-select the brush from the “brushes popup”).

1 Like


That’s so true!. I managed to only pick colors that are different from my foreground…

For sure!. Here they are:

Ok, I tried that, on brushes → saved parameters I’ve choose Foreground color. It worked!, but sometimes when picking colors and switching between brushes, they will turn alpha?.. should I record?.