Can't save as PNG in desktop

I made a sprite, and i tried to save it in my folder as a png, that did not work, tried saving it to desktop, did not work, tried saving it to downloads, It worked. i tried running aseprite as administrator and i could save the file anywhere as a .aseprite file, but i could not save png files to desktop or any folder inside desktop

1 Like

I’m happening same as you. That’s not only png. All other file types expect ase and asprite

Hello everyone! :wave: it looks like a problem with privilegies, are you running Aseprite on Windows or macOS? are you running Aseprite with your user or as administrator?

You can try:

  1. close Aseprite,
  2. then start Aseprite as normal, with your user,
  3. try to drag and drop a .png file from the desktop (Windows Explorer / macOS Finider) to Aseprite
  4. then modify the png and save it File > Save
  5. can you save the file?

I’m having the same thing happen. I was able to save two pngs like normal but the next day I can’t save things like normal.

Aseprite is able to “see” the files but when i open fileexplorer in windows 10 the files aren’t there, and existing files can no longer be overwritten. this includes both PNG and ASE files. I can open them in aseprite even if i open a new tab BUT saving them in the new window doesn’t fix the problem, i just know that the files exist “somewhere” in the folder i saved them to even if i can’t see them?

Closing all tabs fixed my problem and i can save things again.

I’m using: Steam, Windows 10