Color on palette panel didn't same as drawing on the canvas when use color management

Aseprite: v1.3-beta21-x64, Steam
OS: Windows 11

Althoght it’s fine when disable color management or set “Windows Color Profile” to Use sRGB. The color you draw was same as what you pick. But the final color will be different if export to png(drawing color (255, 0, 0) but png color was (249, 0, 34)).

So it’s must use color management. But when set “Windows Color Profile” to Use Current Monitor, the color you choose was different to drawing on the canvas.

For example I set the red color on the panel(255, 0, 0) and drawing on the canvas. I use the 3rd color pick tool to check the actually value: palette panel was (243, 0, 49), canvas was (249, 0, 34). And if I export the image, open with viewer and check the color again, it was (249, 0, 34) match the value as canvas color.


hi, nekolyst!
the colour area and the image colour should be same, i have no explanation for that.

the difference between values you set and export seems to be colour profile mismatch. even though the image you posted is compressed i can tell that the red is indeed not 255,0,0 just by looking at it.
(see the squares below, the original is on the left, on the right is 255,0,0 - they look different on my screen).
so that’s already a problem - the png export is probably correct, it’s just you don’t see the right colours in the first place.
imo colour management is great source of headaches. from what i’ve gathered the only way to make it work is to make sure all devices and software you use are set to same profile.

i’m on win10, but i’d hope this isn’t system specific issue (or that steam affects how colours are shown), so i’d recommend to first check if both window color profile and working space in aseprite settings are set to srgb and then if your monitor and windows color system profiles are set to srgb too.
these are my settings :

(note that “use embedded profile” can cause problems when opening file with different profile than srgb)

Thanks for reply!

Sorry for the compressed gif, here has a screeshot:
The color on color bar and on the canvas are not match if you pick them up.
My expect is both should have same RGB value.

My Windows color management setting is same as yours.

Current solution seems to choose “Use sRGB Color Profile”?

yeah, that’s weird, they should be same. also it’s strange that you can measure different values than 255,0,0.

I think maybe I calibrated the monitor? My monitor has 95% srgb.
I also measure not pure value when select pure color on other software like Affinity Designer.

i’m not an expert on colour management at all, but as i understand it the monitor shouldn’t be an issue - at worst it would display incorrect colours, but you shouldn’t be able to measure them as different and i shouldn’t be able to see that difference (because values would be still same). so i think it’s on different level, since the colours are rendered differently.
usually this would be due to for example system being set up to srgb and then working space in software to something else. can you post the printscreen of aseprite colour management settings? edit: also send the file with red colour exported from aseprite, i’d like to check how it looks on my system.

My aseprite setting:

Exported png:

well, that seems to be ok - the red is 255,0,0. :thinking: does this still appear as 249,0,34? and if so, if you switch window color profile to srgb or switch off the color management, does it change how the colour looks?

I use Honeyview to open the png. It’s (255, 0, 0) if disable use monitor ICC profile and (249, 0, 34) if enable use monitor ICC profile.

I got same exported png file whether change window color profile to sRGB or disable color management

alright, then keep it srgb or disabled (i think srgb should be standard anyway).
i looked into that difference between sprite color and color area values and there’s this option in experimental settings: “use shaders for color selectors”. i don’t know if it’s related, but if it’s on you may try to switch it off and see if it makes any difference.