Compilation Fails in ZorinOS on last two steps [Solved]

Hello, am trying to compile aseprite on ZorinOS (which is based on Ubuntu) and it just simply wont work. Here is the error im getting:

Sooo… yeah. It fails on almost the last step so that is weird. I tried compiling on just a ubuntu 20.04 VM and it works fine. So it looks like Zorin os might not have some package that ubutnu does? I am a programmer but debugging this error makes my head spin. Please help. Thanks.

EDIT: Looks like it is a skia related error becuase of the reference of SkSLFunctionDeclaration, but i still dont know why.
EDIT 2: I think it might be becuase I am building Skia with gcc instead of clang. So im gonna try building with clang and see if that helps. Ill write back once I have the results.
EDIT 3: That didn’t work. I rly have no idea.
Computer: Dell Optiplex 3020
# of Cores: 4
OS: Zorin OS 16.1 (Ubuntu 20.04 Variant)
Skia: Compiled from branch m102
Aseprite: Compiling branch v1.2.39

Issue is solved (see ninja aseprite error: undefined reference to `std::__throw_bad_function_call()' · Issue #3437 · aseprite/aseprite · GitHub)