Copy & Paste suddenly adding colours to my sprites

Hello all! I’ve been using Aseprite for about a month now and have been really enjoying delving into pixelart, I find the program so logical and well made. Kudos to the devs! :star_struck:

BUT today I ran into a very annoying problem that I cannot seem to get around. I am using a limited palette to develop BG assets for a Rogue-like generated world. For some reason only today has it started to copy the background colour (which is on a separate layer) into everything I do.

Before I used to be able to copy and paste the top layer with all its transparencies into other documents but now it takes this background colour with whenever I copy and paste anything. (the branches, trunk and leaves of the tree shown here are normally on their own layer with transparency, not together with the dark blue background)

Have I changed a setting somewhere? I can’t find a way to not have it bring this background colour in now. The only thing I changed is I expanded the palette by one colour but even when I try to use older files which had previously worked, now it always brings in a background colour when I copy and paste.

Any help is much appreciated, thank you! :pray:

You are probably just copying it wrong. Make sure the layer you copy does indeed have transparency by hiding all other layer. Then enable your layer and copy it

It does indeed have transparency and I have been using it in this way for the past months.
I have been using a limited palette on these images and had added a couple more colours. I was copy and pasting between images where the palette was mostly the same except for one or two additional colours at the end. Transparency colour was the same in both and everything else lined up fine so I thought it wouldn’t be a problem… But it turns out that was it. I added the new colour to all the ASE files I am working with and clicked “REMAP” when it popped up and now I am able to copy and paste with the transparency included.

Oh yes if you are working in indexed mode, copying must be done carefully.
Working in RGB mode doesnt have this problem. You can change the color mode of your project in Sprite>Color Mode>RGB


Oohhh man I was looking for that option and couldnt find it. Thanks though, going to keep it in indexed and not add any more colours but glad there was an option to do so without it messing up my files too much!