"Crosshair on sprite" size too small in a 2k monitor

Hi.

I’m using a 2k monitor (2560x1440) and the “Crosshair on sprite” is mini mini mini small haha
I try using the other “Simple crosshair” but I don’t like it, this one doesn’t let me see the background around the pixel.

I would like to use the “Crosshair on sprite”, but a bigger one for my 2k monitor.
Is there a way to make it bigger?

Otherwise I will have to use the mini mini mini small Crosshair, which is a bit confusing sometimes because I don’t find it.

1 Like

Seconded! Even on a 1080p screen, I struggle to see the Aseprite crosshair. For comparison, the Photoshop crosshair is quite a bit larger (Aseprite on left, Photoshop on right):
image

The crosshair, even in non-native mode, doesn’t scale with the cursor scale option, either. I understand that one being separate, but it would be nice if it had size options (or was just larger by default).

A temporary but subpar fix is to swap the UI and screen scaling so that the screen scaling is larger but everything overall remains the same size, this scales the crosshair up. Unfortunately, this also means the preview can never be 1x. I suspect this was the mode that the crosshair was designed around though, which is why it’s so tiny.

2 Likes

Agree with everything.

The temporary fix you propose is not useful for me, because scaling the screen makes some things blurry.

The fix I’d apply is to separate and enlarge the crosshair’s axises depending on screen resolution, to keep them at the same distance and size no matter the screen resolution. This fix shoulnd’t affect to the axises’s width, which should be kept 1 pixel at any resolution.

Also would be nice an option to setup the axises distance from the center point, and maybe also their length.

I meant within Aseprite, in the General settings. This should not be blurry.

It becomes blurry if you zoom out to 50% zoom with 200% screen scaling, even if 50% at 200% is actually just 100% zoom. It’s just because of the render engine handling it that way.

2 Likes

I looked through the theme files and the other setting files and it seems like the size of the cursor is hard coded. You could try to just edit the simple crosshair sprite in the theme to make it less intrusive. You can make it both smaller and semi-transparent which might make it somewhat of an alternative at least.

You can try this example theme edit I made: https://www.dropbox.com/s/mdiv67aqdktqn6q/aseprite-theme-alt.aseprite-extension?dl=0

Should be able to just double click the file to have aseprite install the theme, then change to the theme in preferences.

Yep, I tried and it makes some things blurry. For example the sprite on zoom out, and also the UI is not so defined.

Thanks!

It is a great idea, the problem is when the background has the same color than crosshair… so at the end it is needed to use a 2 colors crosshair.

The best choice for me is using Simple Crosshair with nevatige black and white and be able to setup its size, but I edited the sprite crosshair as you commented and yep, I think the result is pretty fine in comparison with the mini mini mini small simple crosshair and the wider sprite crosshair the theme I’m using contained.

Here the one I created:

Case closed :nerd_face:

@eishiya if you find this one useful here it is the sprite:
https://mega.nz/file/7IAHHaAZ#m9p1z3D0xs2tPjbXpr8iL8GD7no_cTk8eBioC8oPBWA
(I can’t upload another image because it is suposed I’m new in the forum, and my account has some years :roll_eyes:)

1 Like