Cursor Lag -- Possibly Caused by Zoom Level?

I know this has been a problem before, but I’m noticing it in the past week or two, but not before. I have Windows 10, a Ryzen 5 and more than enough RAM. I use a mouse. My monitor resolution is 1920x1080.

It seems to be more persistent at certain zoom levels and on larger canvases, but we’re talking like 256x256 so. I was working on a much larger piece without issue before. It seems to only lag on the canvas as well. You take the cursor off that and it’s fine.

I tested this with a 64x128 canvas, lowest size I tried, and the problem persists when zoomed in tight. Zooming out further is smoother but not like it was before this began. The real problem is zooming out makes it difficult to work in the sprite sizes I use.

Additional notes from more testing:

I restarted my machine. No bueno.
I reinstalled Aseprite. No bueno.
I changed screen scaling from 200% to 100%. No bueno.
I tried changing cursor options. No bueno.
I tried going windowed (I usually use fullscreen). No bueno.

I tried changing the cursor option to Simple Crosshair. Semi-bueno. It seems okay but there’s still some visual lag and as I’ve been trying to use the tool anyway, I’m not sure if the physical lag has actually diminished.

What else can I try? This has been an intermittent issue with Aseprite, going off the google results, since 2017. I cannot find a clear solution since most users reporting it used tablets and other OS’s.

Any help would be amazing since I have projects on the go and this is getting in the way. It makes working impossible.