Edit palette, Textbox input highlighting too quickly

I can’t imagine this is intended behavior.
When you are in edit Palette mode, when trying to manually type in values in the text boxes (except the hex code) the text will highlight within a fraction of a second. So it you are typing “128” and you take too much time between “12” and “8” the text will highlight and you will be left with just 8!

- In this image I am literally pressing nothing but 1 2 and 8. This only happens in Edit Palette mode.


That’s a nice find. To expand on this, it only happens in Edit Palette and only when you are editing a color indexed in the palette.

It doesn’t happen if Edit Palette is disabled or if you are trying to edit a color not in the palette (so Edit Palette can be enabled but if you’re changing a color not in the palette, it won’t occur).

The latest stable version is also kinda less temperamental about that color panel. You can move the cursor outside the panel and it won’t auto close it like in the beta version.

1 Like