Errors building from source

Hello. For the past week or so I’ve been trying to build aseprite from source, but have been getting a weird error:

C:\aseprite\build>cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DLAF_BACKEND=skia -DSKIA_DIR=C:\deps\skia -DSKIA_LIBRARY_DIR=C:\deps\skia\out\Release-x64 -DSKIA_LIBRARY=C:\deps\skia\out\Release-x64\skia.lib -G Ninja ..
CMake Deprecation Warning at CMakeLists.txt:16 (cmake_policy):
  The OLD behavior for policy CMP0046 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.

-- The C compiler identification is MSVC 19.29.30133.0
-- The CXX compiler identification is MSVC 19.29.30133.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - failed
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.29.30133/bin/Hostx64/x64/cl.exe
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.29.30133/bin/Hostx64/x64/cl.exe - broken
CMake Error at C:/Program Files/CMake/share/cmake-3.21/Modules/CMakeTestCCompiler.cmake:69 (message):
  The C compiler

    "C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.29.30133/bin/Hostx64/x64/cl.exe"

  is not able to compile a simple test program.

  It fails with the following output:

    Change Dir: C:/aseprite/build/CMakeFiles/CMakeTmp

    Run Build Command(s):C:/PROGRA~1/CMake/bin/ninja.exe cmTC_425b7 && [1/2] Building C object CMakeFiles\cmTC_425b7.dir\testCCompiler.c.obj
    [2/2] Linking C executable cmTC_425b7.exe
    FAILED: cmTC_425b7.exe
    cmd.exe /C "cd . && "C:\Program Files\CMake\bin\cmake.exe" -E vs_link_exe --intdir=CMakeFiles\cmTC_425b7.dir --rc=rc --mt=CMAKE_MT-NOTFOUND --manifests  -- C:\PROGRA~2\MICROS~4\2019\COMMUN~1\VC\Tools\MSVC\1429~1.301\bin\Hostx64\x64\link.exe /nologo CMakeFiles\cmTC_425b7.dir\testCCompiler.c.obj  /out:cmTC_425b7.exe /implib:cmTC_425b7.lib /pdb:cmTC_425b7.pdb /version:0.0 /machine:x64  /debug /INCREMENTAL /subsystem:console  kernel32.lib user32.lib gdi32.lib winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib advapi32.lib && cd ."
    RC Pass 1: command "rc /fo CMakeFiles\cmTC_425b7.dir/manifest.res CMakeFiles\cmTC_425b7.dir/manifest.rc" failed (exit code 0) with the following output:
    The system cannot find the file specified
    ninja: build stopped: subcommand failed.

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:31 (project)

-- Configuring incomplete, errors occurred!
See also "C:/aseprite/build/CMakeFiles/CMakeOutput.log".
See also "C:/aseprite/build/CMakeFiles/CMakeError.log".

I have followed Microsoft’s instructions on reseting the OS to fix the PATH variable (i may have mucked it up, which is why I was getting these errors) but I still get this error. I have reinstalled Visual Studio (losing all the plugins I had, but that’s honestly fine, I can install them again later) and checked all the versions of each module/program that I need. I’ve watched several videos online to see if I missed something, checked forums and Stack Overflow, nothin. I’m at a loss as to what is going awry.

Any and all help is greatly appreciated c: Thanks!

EDIT: I tried doing it with a command prompt opened as administrator (which I am 70% sure I tried before) and it seems to be working now. You will know if it worked by the presence or lack thereof of further edits.