Exported layers visibility does not takes parent group's visibility into account - v1.3-beta10-x64 Win10

Hi there, I was exporting a group which contains sub-group, containing more children layers. But it appears that those children layers ‘ignores’ the parent group’s visibility flags and are included whenever they’re visible, whether or not if the parent group is visible or not.

Here’s more details about this behaviour:

The group susguy contains two sub-groups: meatconsummer and summoner. They contains two spritres (seen above) that I’d like to export separately, via setting one group invisible and visible for another group, before exporting the main group susguy.
Normally, the expected result of above setup is an image that only contains one of the sprite shown in the image above. (since only one of them is visible) But whenever I do export, both of the groups seem to have exported as if both had their visibilities on – When in reality, one of them had their visibilities turned off.

I assume that this behaviour is happening because the children layers has their visibilities (internally) turned on and are ignoring their parent group’s visibility.
To confirm this, I tried to export with the setup where the group summoner has their visibility turned on, while its children layers are invisible – And of course, it resulted in expected behaviour with only one of the groups exporting.
So this must be an issue where the children layers are ignoring the parent groups visibility settings while exporting.

My current Aseprite version is the following: Aseprite v1.3-beta10-x64, Running on my Windows 10 machine via Steam.

I’d be down to give you more details regarding this if needed, since it seems that I cannot embed more than one images in a post for now.
Cheers, ZIK.

1 Like

Hi @TandyRum1024,

I tried to recreate the issue – same version, OS and also via Steam. What export settings are you using? I found my results varied depending on the option I selected in the Layers dropdown menu. I included screen shots with thumbnails enabled in the timeline so it would be clearer to see what layers were being included or excluded in the result.

Visible Layers:


Selected Layers:




Have you exported on previous versions of Aseprite? If so, has the behavior changed from older versions to the current one?

Best to you,

same error happens when i try it - win10 1.3 beta10

nested layers (group 2 is hidden):

export settings (export parent group 3 only):

expected output:

actual output (the violet square is layer in group 2):

as a bonus aseprite doesn’t refresh the canvas and timeline, so you can see the incorrect output in application as well:

Hello! I should have included the full export settings image (but somehow forgot to do so after hitting the limit & removing most of the images)… But I’ve used the Group settings to export in the case above. Here’s the image showing the exact settings I’ve used – As you can see, I’m exporting the group themself rather than whole image nor individual layers:

Thank you,