Fill Bucket issue

suddenly after working fine the fill bucket now ignores all me pencil lines and filles the whole area rather than the outlined i have try the conituous box on and off i have played with tollarance and nothing is working pleas assist

:smiley: Could you attach a screenshot of Aseprite with your project open? Would help a lot to figure out what’s wrong.

Are you perhaps working on a different layer than you think you are?

I believe the problem is that the contiguous box is unchecked when you bucket fill. Check that box and then try again. Please post more screenshots if this does not work.

1 Like

for now it seems to be working again.
as i stated up the top it wasnt working regardless of the contiguous box
there was only ever one layer.
asprite put my account on hold for trying to respond to the first person with the pictures…

There are 2 settings that can cause this and you need the right combination to avoid the behavior you were seeing.

With contiguous mode off, you will fill the whole canvas in your example.
But with it on, you will still fill the whole canvas if your tolerance is 78 (as it is in that screenshot).

If you have contiguous on and 0 tolerance, it should never spill out. You said you played with the settings and it made no difference, but you must not have tried those exact settings.


I am having the same issue with my settings at 0 and contiguous mode off for paint bucket.

Has there been any updates or any new info around this?

My aseprite version is 1.2.17 and I’m on a Mac with Mojave

Thanks everyone!

Contiguous mode should be on if you want to fill only the connected (contiguous) area. When it’s off, then all pixels of the matching colours are filled, even ones not connected to where you clicked.

Thanks for responding! @eishiya

I’m still having the issue when it’s on as well. I’ve tried toggling it on and off and resetting the tolerance to 0

Still having the issue unfortunately :confused:

Here is a screenshot with contiguous on:

Same results when I toggle it off

Thanks for the help!

The only other thing I can think of is that you have 8-way connectivity selected instead of 4-way in the Fill settings. Click that little sliders button to check. You usually want 4-way connectivity.

1 Like

That fixed it!! Thank you!!

1 Like