First day. Pasting from one "sprite" to another and it won't "uncompress"?

Hi. Not an artist by trade so not much practice with graphics apps. But I copied the image of a tree that I like, and pasted special to a new sprite. It’s about 200x200. Then I adjusted the sprite by reducing the amount of colors using the palette options. I did not save it because this was all temp. Now I’m trying to copy my updated tree into another sprite file of trees, but I get:

A problem has occured

too much data to uncompress for the image.

Just like me to find a weird issue on the first hour of playing around. :stuck_out_tongue:

1 Like

what were the dimensions and how heavy was the file? also what whas the extension of the file?

This guy: image

is an asesprite file (at this point). He’s 4 colors and approx 100x100. He wasn’t always 4 colors or 100x100 but I was using him to experiment.

This guy: (it was a green fir tree but I am too new to post two images!)

is about 14 colors and ~150x150.

Trying to put the (red) oak into a layer on the fir (green) tree gives me the error. I just tried it again now that these two files are saved and it still gives me the error.

1 Like

I am having same issue would love to hear why this is happening. I am also new to this program

1 Like

Hi there, sorry for the inconvenience. We are investigating this issue. If anyone have a file that we can use to reproduce the problem, please send it to us to

OP here. I don’t remember what I did, but a lot of color indexing doesn’t do quite what I expected! It works but I expected magic (remember I’m a newb to graphics creation in general).

Short answer: I probably switched my destination to RGB (Sprite > Color Mode > RGB) and maybe my source as well, then copied and pasted.

Indexed (color map) mode I had assumed would be pretty magical and “do what you mean,” but it seems it’s more of a “write only” tool. For instance, if I have an indexed picture of several reds and I paste it into an indexed picture of greens, the colormap is not appended or adjusted.

I’m afraid the files are long gone. Maybe I’ll try to reproduce them if it helps.

Sure, if you have the exact steps to reproduce it, it would be awesome.

I forgot to write back but I have not been successful at reproducing the issue. I tried for about 30 minutes. If I run into it again I’ll add it here. Sorry!