Grid and Rectangular Marquee Tool bug

Hi, I have tried something that i believe it is bug. I use to hide grid with crtl + H . It is working until you hide grid and use rectangular marquee tool. I select area i copy and paste (ctrl + C , ctrl + V ) then i try to visible grids (crtl + H) . It doesn’t appear when i press ctrl + H. I have to do it manually active it from the menu.

hi, what version are you using? i just tried that in 1.3 beta and it works fine.

1 Like

oh i might be in old version. I am in v1.29

It is better i make for you a video. It is hard to explain the situation. New update doesn’t work. :neutral_face:

main city.aseprite - Aseprite v1.2.29-x64 2021-08-31 16-46-03 i don’t know how to download v1.3 steam says that i am up to date.

yeah, that’s what i tried. interesting. just to be sure, if you switch to default theme, does it behave the same way?
btw. here’s how to get beta on steam if you want to try it: Aseprite - Beta

Hello Olga,
I have changed theme and Upgraded new version. I have the same problem.

hmm… so i’ve even installed 1.2.29 and i still can’t replicate this problem…

however, i checked your video again and noticed one strange thing: when you make a selection, there are still marching ants visible (selection border). but that shouldn’t be the case and it never happens to me when extras are off. it basically seems like you don’t switch off extras, only a grid. really strange.

anyway… because show grid has its own shortcut (ctrl + '), you can change it for something easier to reach (for example alt + h), so you don’t have to switch it through menu.
not a solution, but that’s all i can offer now :expressionless:

1 Like

alright, here’s an update. to get what i see in the video i have to:

  1. switch extras off
  2. swich grid on
  3. switch extras on (nothing happens)
  4. switch extras off (grid is off)
  5. switch selection edges on (this switches extras on while keeping grid switched off)
    make selection, copy, paste, whatever - this part doesn’t matter because the result is:
    extras are on, grid is off, so ctrl+h will not show it.

definitely a bug.
imho it is strange that one can even switch selection edges and grid on without extras being on as well. but it might not be an issue if switching grid on switched extras on just as activating selection edges does.

1 Like

Thank you for advice. If i find any clue i would like to feedback here !

Well. I believe that something is going wrong here. :joy: I will make ctrl +h to grid mode on/off

1 Like

Hi @Bora_Kusoglu :wave: I was able to reproduce it, it looks like a bug.

2 Likes

Nice to hear it! I hope you can fix this as soon as possible. Have a nice day!