How do I turn off grid mode?

Once I was doing tiles for my custom game and after that I can’t turn off grid mode. Everytime I turn it off it just starts again in the new sprite

In Edit > Preferences > Grid, select “Grid for New Documents” in the dropdown, and uncheck “Visible Grid”.