How to avoid blurry images when scaling the sprite/image?

If when you use the Sprite Size you are getting blurry images, it might be because the “Bilinear” algorithm was selected, switching back to Nearest-neighbor should solve the problem:

Screen Shot 2020-02-08 at 09.48.25

In case that you are not getting the expected result when scaling the selection, it might be related to the scaling algorithm selected in the context bar, you can try going back to the default algorithm Fast Rotation:

Screen Shot 2020-02-08 at 09.48.17

Finally, if you see a blurry image when you zoom out (zoom level less than 100%), you can disable the Edit > Preferences > Experimental > New render engine for sprite editor option.

1 Like