I am having trouble trying to compile skia

I have fixed things and I am now getting this error

D:\deps\skia>gn gen out/Release --args=“is_official_build=true win_vc=“D:\Program Files (x86)\Microsoft VisualStudio\2017\Enterprise\VC” skia_use_system_expat=false skia_use_system_libjpeg_turbo=false skia_use_system_libpng=false skia_use_system_libwebp=false skia_use_system_zlib=false target_cpu=”“x64"” cc="“clang”" cxx="“clang++”" clang_win="“D:\deps\llvm”""
ERROR Need exactly one build directory to generate.
I expected something more like “gn gen out/foo”

I have the same problem and I dont know solution…

Do you know a solution?

I forget how I solved it, but I was using my D drive while the tutorial and the program is set up to be on the C drive. I would say make sure you are using the C drive

I reinstall VC to C drive, copy deps and aseprite source code folders to C drive but its not working… Can you remember please how do you solve this problem…(Im very need it)

Hi I also had this problem. The --args should be held as one parametr closed in ‘’ (single quotation marks) and another quotation marks inside like path to win_vc should be escaped. I had to manually rewrite the --args line and then it worked. Hope it helps.

Thanks dexxter24, but I yesterday fix this problem. Im just reinstall all tools to C drive and its works

1 Like

I fix this problem by using PowerShell instead of CMD.

Hey, I found a solution for me that was putting an inverted bar before all double-quotes.