If my pixel art animated has more than 6 frames, it appears blurry in Unity in the Scene/Game

This is cross post from the Unity forums.

As the title states, I’m importing pixel art of a simple monitor into Unity (by saving the file directly into the Assets folder), and the logo will be glowing gradually with 26 frames. The game is in 2D only.

When I import that into my game in Unity, the monitor looks blurry, even though it’s still animated.

I tested this by duplicating it and removing frames in Aseprite, and found that at 6 frames exactly, the pixel art returns to the normal one I created in Aseprite.

I’ve checked other threads on the web and in Unity I’ve set Filter mode as Point (no filter), and no compression.

I’m new to Unity, and Aseprite, so I’m not sure if this is a limitation of the Unity preview, or that there’s too many frames to show, or a setting I’m not enabling, or something wrong with the way I saved it in Aseprite?

I’ve attached screenshot showing the correct model on the left, and the blurry version on the right (with the full number of frames).

Any help you can provide would be great.

Okay, I solved it, I’ll let everyone know what the answer was, I changed ‘Max size’ in Unity to 8192, presumably because the ‘sprite’ took up a lot of space being animated that way.

Perhaps I’ll try to split it up so the animation is only for the small logo on a separate image, in order not to bloat the game artificially.