Indexed Mode: how to disable auto color remap while copy-pasting?


I’m working on some retro systems (consoles, arcade boards) which have specific palette requirements, usually 16 colors per sub-palette. Order is very important and indexes can’t be shared between palettes. Palettes are linked to tiles and tiles can’t use more than one palette. I’m new to Aseprite, but I enjoy its potential. I know that Aseprite only really manages one big palette of 256 colors, but it’s a very useful tool to manage palettes by pseudo-groups of 16 colors.

Here’s my problem. I’m trying to copy-paste on a single canvas several graphic elements with their own indexed palette of 16 colors. Whatever I do, Aseprite will insist in automatically remapping colors from my objects to similar ones already present in the canvas. I definitely don’t want this, I’d like Aseprite to strictly stick to the original indexes of my palettes (even if they’re full of the same color).

By experimenting a bit, I found that Aseprite will stop auto remapping if the RGB values are 8 increments away from each other. Example:

First index (color 0) in my canvas palette (palette 0) is 0,0,0 [this is index 0].
First index (color 0) in my object palette (palette 1) is 5,5,5 [this is index 16].

Aseprite will remap index 16 to index 0.

If I change the value 5,5,5 to 8,8,8, Aseprite will not auto remap and it will correctly use index 16.

I hope it’s not too confusing, I can provide better screenshots to explain my issues. Maybe there’s already a feature to prevent Aseprite from auto remapping colors when copy-pasting between two projects, but I haven’t found it.

Hey @Kaminari, I’m not entirely sure I understood what you meant, but here’s an option to what I got:

Before importing new artwork to your canvas try changing from Indexed Colors to RGB, you can do it by browsing the top menu Sprite >Color Mode >RGB Color (this way you’ll keep the palette you’ve got previously). Aseprite - ChangeColorMode

If after adding the new Artwork you’d like to keep the new colors in your Palette Tab as well you’ll have to add the colors one by one (not sure if there’s a better method).
Aseprite - Indexing Colors

And after all that you can turn your file back to Indexed Colors!

Please let me know if that helped!

1 Like

Is there a way to change this color mode to the default?

When you have a new question that’s only tangentially related to an older one, please make a new thread instead of bumping an old one.

When opening saved files, Aseprite will use whatever color mode they have. So if you save them in RGBA, they’ll be RGBA next time you open them.
For new files, you select RGBA/Grayscale/Indexed when creating the file, and that setting will be remembered for the next time you make a new file. So, if you always make files in your chosen color mode, it’ll always be selected as the default.