Inks not working properly

Hello friends. In the latest version, did you noticed something strange with inks? I think there is something wrong with them - Copy Alpha + Color especially and Alpha compositing - it is worst when you swap between them - once done you go from one to another there are 2 things that can happen - the brush acts like normal ink without alpha or other when your opacity is lower than half the value - it is completely transparent - just nothing happens there and all other inks start behaving strangely - mostly like there are simple Ink, regardless the alpha values. Sometimes I notice them drawing behind. But in general changing from one to another ink lead to very strange results. Did you noticed something like that or is it just me?
Best Regards.

Hmm I’m not super familiar with how any of those inks work as I don’t use them, but I can’t seem to find any strange behavior here from a quick test at least, in 1.2.16.3.

If you do find a way to consistently make it behave strangely I could try to recreate it using that method but otherwise I don’t know.

Go new file for example 256 x 256 indexed, go brush, 30 px. with light blue color.
Make a line with simple ink.
Go orange color for example and make Alpha compositing ink with 38 opacity. You can get after that and choose any color. As you can see the ink is drawing BEHIND other inks in the current layer, not in front of them with some transparency and mixing - as it should be. The brush is completely opaque just draws behind, and if you want to check whether it is completely opaque as seen while drawing you can make another layer behind current one and then paint it in another color with the bucket. there you are - the ink is not transparent.
Make another choice - take green and get opacity to 98 then go and paint on orange and blue - as you can see now it is partially transparent over one of the colors and behind other - the blue line is not touched.
Make transparency 149 which is above the middle range and start painting - now the green is transparent on some colors like orange violet etc and completely opaque on blue color - you can make opacity 255 and there will be no difference.
Go on transparent BG without any pixels we already drawn and if you go for low transparency - the brush is opaque, go for high transparency (not 0 ofc.) and the brush just does not paint.
It is not how it worked and it is not how it is described in the docs of the program.
Lock Alpha is working in aspect of locking to the current colorful pixels if the surrounding is transparent, but the same transparency result - low transparency means there will be no effect what so ever on the pixels you draw on.
Copy alpha + color according to the documents and to how it worked should change the color of the pixels with the chosen of you (foreground on the brush) but will keep the transparency of the pixels - for example 128 (documents), well the ink works as normal ink.
Another example? Make blank document no BG, go for mmm green color with 32 transparency alpha compositing. The ink is opaque and below 32 it is just no ink there. now go red, just change the ink color to red and with the already selected transparency of 32 try to draw - well it still draws BEHIND the opaque ink that should have been transparent.
Shading works fine - if you are in one of the gradient colors and LC it paints with next one. This one works fine.
The more you swap alpha inks the bigger the issues become.
I have tested reinstalled deleted the user folders and reinstalled etc… nothing works.
According to the documents and to what the inks where before -i think this is not the intended way of them working. And yes the same last version we are talking about.
With Respect.

P.S. I will search for older version that the things worked properly, I use those and they are unique option in this program (never seen them in other actually), and they worked according the documentation of the program that you can make here:


Maybe it is my problem and I do not understand properly what they should do?
Best Regards.