Issues when I use middle mouse to pan

Hi there! I tend to use the middle mouse button to pan the view on Aseprite because that’s what I’ve gotten used to but I have an issue:

Sometimes this works fine, other times it resets my view horizontally. Meaning, after pressing the middle mouse button to initiate a pan the horizonal scroll bar resets to the far left.

This is pretty annoying and happens seemingly at random.

I know I can use spacebar and left click to pan as well but anyone have any clue why I’m having this issue? I thought maybe there is a setting or keybinding I could change to fix this.

Thanks in advance!

Welcome @Nerevar87, that behavior is odd, are you on Windows? macOS? or Linux?

Could you give a try if disabling the Edit > Preferences > Editor > Auto-scroll on editor edges option fixes your issue? Just to check.

Hey thanks! And thanks for the reply! Sorry, I should have given more info, using Windows 10 Aseprite v1.2.25-x64 on Steam.

I just tried your suggestion but I’m getting the exact same behavior. Sometimes it works fine, other times the horizontal view just resets seemingly at random.

It’s a bit hard to reproduce but I managed to get a gif of the problem after a few tries:

The reset happens near the end of the gif. I made sure not to be accidentally touching any other keys or buttons on the mouse, during the whole gif I’m only pushing and holding the middle mouse button to pan.

1 Like

Thanks for the info and video @Nerevar87, I’ll take a look to this later on my Windows PC.

I tried reproducing this issue (I’m also on Windows 10 and have the same 1.2.25-x64 Steam version of Aseprite) but after a few minutes of MMB panning, it didn’t happen even once. The closest I was able to get is by interrupting my mouse drag with my tablet stylus, but even that wasn’t a reset to a specific location, but a sudden change to where the cursor now was.

Have you tried disabling your extensions (looks like you have at least one) just to make sure it isn’t one of them causing this? If it’s an extension, then perhaps it just needs some debugging, or if it’s bug-free, then perhaps there’s a bug with Aseprite’s scripting API. Either way, it’d narrow down the issue somewhat.

@dacap Thanks!

@eishiya Sorry, I don’t think I have any extensions, what makes you think I do? (Maybe I do and I’ve forgotten haha)

The colour pickers visible in your screenshots, I’m not aware of a standard way to pin them like that, so my guess is that’s done with a script. Of course, I don’t know every Aseprite feature so I could be mistaken xP

Oh, I don’t think so, all I did was open them up and drag them out there and they stayed pinned haha

1 Like