Move/copy/cut selection across multiple layers / layer group at once

I found myself searching for this so many times and could never find a definitive answer: I just want to copy my current selection across several layers.

I tried to select the layers before a rectangular selection, the frames before a rectangular selection, start with the selection then select the layers of frames, but never found a way to copy the current selection across multiple layers.

I also tried to just select the layers/frames to copy the whole image across them, to no avail. This is one of my biggest issues, not just with Aseprite, but with graphics editors in general, when they don’t support this feature.

The suggested workaround (on both Aseprite and Krita forums) is either:

  • flatten the layers, then copy the selection → but it’s a destructive operation that requires to Undo before you forget
  • export the layers together into a new image and use that → not very convenient when you jsut want a quick copy; also, if you only need to copy a small part of the image, it will still export the very big image, that is mostly transparent

The only operation that works simply across layers is Move (V) which just works after you selected multiple layers. It doesn’t work when doing a selection then dragging the selection though, only with the Move tool - which means you move the whole layer, not just the selection. Even when selecting a group, if you checked the “Auto-select layer” option, Move tool won’t move all the layers under it as it will switch to selecting only the layer under cursor as soon as you click: you still need to select the multiple layer you want to move first. If unchecked though, it will move the group as wanted.

So I’d like to be able to move/copy/cut just a selection, or copy/cut the complete image, across multiple layers, when those have been selected (before or after the selection is made).

I discovered Group today and thought they would fix my issue, but surprisingly, after selecting a Group, you cannot select anything: selection just seems to select empty things, and dragging/cutting/copying it will do nothing. So it looks like a Group contains an empty layer, but you cannot paint on a group so no, it’s not a true layer, but it doesn’t propagate operations through itself either. It’s only an organization tool to toggle visibility and lock across children, and to make it easier to Move whole layers at once; which we can already do via batch select.

So it would be nice if we were also able to move/copy/cut selection across children layers of a group, when that group is selected.

Hi there. The following actions are available in Aseprite:

  • You can select and copy a range of cels (on the timeline), and paste to another region of the timeline, so you can copy a multi-layer/multi-frame image without needing to flatten the image.
  • You can select and copy a range of layers (on the timeline), and paste it to the timeline.
  • You can select and copy a range of frames (on the timeline), and paste it to the timeline.
  • You can copy a selection as a merged multilayer image -single frame- (Select an area, go to Edit > Copy Merged).
  • You can transform a selection across multiple layers:
    1. Select the image portion to transform.
    2. Select the range of cels to apply the transformation.
    3. Transform de image (Note: the transform preview is limited only to the last cel selected of the range, it’s pending a full transform preview).
    4. Pres Esc key or click outside the selection to cancel the selection (the transformation will affect to all selected cels).

Currently, Aseprite cannot Copy/Paste a multilayer selection, it’s a pending feature: Enhancements to transform multiple cels · Issue #2144 · aseprite/aseprite · GitHub