Muted colors in Aseprite

Granted I’m pretty new to Aseprite, but the colors in my palettes all seem muted.

Attempting to choose pure red in terms of rgb e.g. (255,0,0) doesn’t yield what I would call pure red. Mousing over the color that Aseprite calls rgb(255,0,0) with the digital color meter on my Mac confirms this. It reads as rgb(217,68,50).

Can anyone explain what’s going on here? Is there some Aseprite setting I’m missing or some color concept I’m not understanding?

hi, jonathan!
my guess is this is related to color management.

first, try this: set some colours - for instance pure rgb. paint with them on canvas, export the image and open it in another application which does have proper colour display (photoshop, image viewer, browser, doesn’t matter). now measure the colours from that image. are they correct?

if so, than it will definitely be issue of colour profile. hence the second thing would be to go to edit -> preferences -> color and set correct settings.

you can switch off color management to see if it’s going to help. what are your colour settings there?
you usually want to have color profile of any of your applications same as colour profile of your monitor / display.

Hi Olga. That suggestion on color management was exactly correct. My color profile was set to “Current Monitor” - switching it to ‘sRGB’ or turning off color management altogether corrected the issue I was seeing.

I just did not know how to access the color profile settings. Now that I see where they are, I’ll experiment with them.

Thanks so much for the helpful reply!

1 Like