My Eraser is Broken

I’m not sure how/why but it’s stuck in making new colours rather than erasing them

I’m trying to practice the basics, I can’t do so if I can’t erase my mistakes and do them over

Do you mean the actual eraser tool, or right-clicking while on the pencil tool?

I’m honestly not sure, I’m using a MacBook and no mouse

It suddenly turned to this background/foreground color when I was trying to learn Hues

I’m not really sure what you mean. Can you take a screenshot, or record a video of the issue and link it here?

If you’re right-clicking and you have the Eraser active, it could be replacing the foreground color with the background color, but if that’s not what’s going on, a photo or video would help diagnose the issue.

I tried erasing the green and instead I get this color

It looks like you’re using the Pencil tool (or some other drawing tool), instead of the Eraser tool. Try pressing ‘E’ or selecting the Eraser on the right hand side. Something else might be going on, a video or screenshot of the whole Asesprite window might help.

I made a quick gif that shows the effects of the Pencil and Eraser tool, in case it helps.
I have white as the foreground color and black as the background color
and first draw a white line by left-clicking with the Pencil tool
then a black line by right-clicking with the Pencil
Then I switch to the Eraser,
and left-click, which brings both back to transparency,
then right-click, which replaces the foreground color (white) with the background color (black), but doesn’t affect anything else.
This is all on a normal layer, not a background layer (you can press Tab to open the layer/timeline editor)
Can you describe what you’re doing a bit more?

No, I really am using the eraser tool, it’s not erasing the green it’s filling with some other colour

I’m not sure what I did to break or change the eraser tool

And yes, I know it’s the one right below the pencil

Ah, I see now. You’re drawing on a background layer, so the Eraser tool is essentially drawing your background color instead of erasing. If you look at the bottom left, your background color is a translucent gray, not a complete transparency. I would either create a new layer (shift-N) and work mainly on that, leaving the background layer as a whole color, or change the layer you’re working on to a non-background layer (right-click it > Layer from Background), or change the background color to complete transparency (option-right-click outside the canvas [I think option, not sure on mac. You could also manually select the eyedropper, or click the color and manually change it])

It seems to have something to do with Background

Any idea how to erase in the background?

Thanks, I just switched to a regular layer, I’m not sure what’s the exact difference between background and Layer though

It’s just a special layer that’s always at the bottom and fully opaque. Nice if you’re doing something for an application where you don’t want transparency.

Okay, any way to erase the stuff for background though?

Also, thanks, going back to learning the basics, constantly nervous just trying

Backgrounds are completely opaque, erasing on them will always use the Background colour (hence “Background colour”). If you don’t want a background layer that behaves like this, you can safely delete it or convert it to a regular layer.