Need help asap. Linux/Pop OS

I’m on the first day of a game jam and have spent 6 hours on pixel art only to not be able to find my work! I was happily “saving” my work and closing the app throughout the day. I would reopen my app and all my old work would be there. I decided I had completed enough work that it was time to back it all up to a flash drive. I could see the files through Aseprite, but couldn’t locate them in my files system. I searched .ase and .aseprite through the CLI and couldn’t find anything. I literally went through thousands of .png’s to try and located them manually. When I tried to save anywhere else it said that I didn’t have permission. So I went through steam, right clicked and went to file location. Found the aseprite app and right clicked it and set read/write permissions and tried again. There was no different. I went back through and changed permissions from my user name to “SUDO” and now I can save files where ever I want and actually see them in the file browser BUT I CAN’T FIND ANY OF MY PREVIOUS WORK!
my asprite. ini still shows the paths that has my work, but I can’t find/load any of them!
_ = true
0000 = /Aseprite Saves Maybe/PixelartMobo1.aseprite
0001 = /home/defunct_username/Desktop/New Folder/PixelartMobo1.aseprite
0002 = /home/defunct_username/PixelartMobo1.aseprite
0003 = /home/defunct_username/OldRecordPlayerPixelart.aseprite
0004 = /home/defunct_username/RecordPlayerPixelart.aseprite
0005 = /home/defunct_username/StereoPixelart.aseprite
0006 = /home/defunct_username/StudiomonitorPixelart.aseprite
0007 = /home/defunct_username/RadioPixelartBrown.aseprite
0008 = /home/defunct_username/RadioPixelart.aseprite
0009 = /home/defunct_username/TubeAmpPixelArt.aseprite
0010 = /home/defunct_username/RFgenPixelart.aseprite

_ = true
0000 = /Aseprite Saves Maybe
0001 = /home/defunct_username/Desktop/New Folder
0002 = /home/defunct_username

in .var/app/com.valvesoftware.Steam/.config/aseprite/sessions/ I can see all the celdata and img files but I can’t open them with anything.
in .var/app/com.valvesoftware.Steam/.config/aseprite/files/ I can see all of the .ini files for all the work I’m trying to recover but it just shows stuff like :
type = 0
size = 16 16
zoom = true
color1 = rgb{128,128,128,255}
color2 = rgb{192,192,192,255}

grid = false
pixel_grid = false

Hi @BD_Jones, this is the first time we saw something like this on Linux. Is Steam virtualizing your file system for each executed game/app?

Could you please try running the following command in the terminal/console:

locate PixelartMobo1

As last resource, please compress the .var/app/com.valvesoftware.Steam/.config/aseprite/sessions/ folder and send it to us at, we might try to recover the files (anyway it’s Saturday and I’ll not be all day in the computer today).

I had to travel out of state for a job. I tried locate PixelartMobo1 and this was the response:
/home/defunct_username/.var/app/com.valvesoftware.Steam/Desktop/New Folder/PixelartMobo1.aseprite

@dacap I really appreciate you following up. It seems that after I granted aesprite SUDO privilege, I had to “recover” the files. Initially it only looked like it recovered the last session but it’s since become apparent that the other session data is still available. I’ve got two days left to the game jam so I think I’m good.