Need help - Recover File Session Not Showing


I was working on an aseprite file (I think I started and worked with it around Oct 13-15), and left it a bit and worked on some others, but I forgot I had yet to save it after all the work done on it.

Recovery settings are set to 2 mins in Aseprite and it was open for a couple of days, so it should have at least some recovery file sessions right?

The thing is I kinda left my PC with Aseprite open for a while (probably about a day) and Windows Update kicked in with its stupid auto update while off-hours feature, most likely while I was asleep (and most likely closed Aseprite in the process), and I just found out that I lost all my progress on it.
I tried to check the Recover File option but unfortunately, the latest crash sessions and previous sessions don’t include any files for Oct 13-15 on the list.

I checked the sessions folder and I do see some files for Oct 13 and 15 but they don’t seem to be listed in the recovery list in Aseprite.

Any chance that there is something I can do to check these files if one of them is the file I was working on?

(Sorry for the single image, couldn’t post them separately since I’m a new user in this site.)

Edit: Forgot to list my aseprite version: v1.2.25-x64