Os.execute function not working

I am running the Steam version of Aseprite on Manjaro KDE.

When a plugin attempts to run an external application using the os.execute function nothing happens.

For example, I would expect the following to open my web browser to aseprite.org, if I run this command from a terminal it does just that, however from Aseprite it does nothing.

os.execute('xdg-open "aseprite.org"')

If I use the Aseprite lua debugger to run the above lua code I get an error in the console. Even though the below is an error for io.open I assume it is because os.execute is using that under the hood, as I get the same error if I try io.open as well.

[string ""]:1: no debug information (script filename) to secure io.open() call

This is leading me to believe that there is some security setting preventing the function from running. Is this correct? If so, where can I change this setting? If not, does anyone have any ideas on something I should try?

Doing a bit of testing and I found that the os.execute function is working if I do something like the following, the result of this is creating the file as expected.

os.execute('echo "testing" > ~/test.txt')

It seems the issue is calling anything that should result in opening a new window.