Outline tool not working?

I installed the program last week, outline worked for a couple of days but now does not function at all, either with Shift O or the Edit > FX menu. I have tried unchecking preview, tiles, changing the shape and colour etc. but nothing helps - after I click O.K a small menu briefly flashes for a second but I can’t see what it says. It makes no outlines at all, I have tried with different size images too but nothing seems to help. I am using single frames.

Perhaps I am doing it wrong? I thought it was just Shift and O, choose a colour, click OK and it is done, perhaps I am missing something? That says ‘preview’ but there is no preview window.

If you’re able to post a screen shot of the outline dialog, that might help clear things up. Some themes, such as the default dark theme, can make it difficult to tell what effect settings are active vs. inactive.

In the mean time, here are some diagnostic questions:

What RGBA or Index channels are active for the outline effect (look under the OK and Cancel buttons)?

Is the outline set to target Selected or All (look under the RGBA channels)?

What is the sprite’s color mode when this problem crops up: RGB, gray, indexed?

If the color mode is indexed:

  • Is there at least one and at most one color with zero alpha in the palette?
  • Are that color’s other channels – R,G,B – of that color also zero?
  • Is that color located at index 0 in the palette?
  • Is that color set as the sprite’s transparent color (Sprite > Properties, under the Advanced section)?

If you don’t know how to rearrange the palette, check this out: https://aseprite.org/docs/tutorial/#color/palette .