Palettes not showing

Hi, I already have my custom palettes in the palettes folder but isn´t showing when selecting palettes in Aseprite. What should I check?

There’s two ways to work with custom palettes that I know of, but I’m not sure which one you may be referring to.

The easiest most straight forward way is having some folder where you may save some palette from a sprite or download one from the Internet, then click the icon > Load palette, then select a file. It will replace the current palette with the colors in the loaded file. (Protip: you can select png or aseprite files in that open file window and it will auto load the palette without opening the images).

These don’t show up anywhere in the UI. You have to load them manually and you don’t really have to store them in any special subdirectory in Aseprite’s installation or config folders.

The other one is via the Presets button (that square icon) where there’s plenty of preinstalled palettes, like A64, EDGE8, Game Boy, etc. Those are actually “palette extensions” (you can get a list in Edit > Preferences > Extensions) and the way to set those is slightly more complicated AFAIK. I could be mistaken but you’d have to create them via this process:, i.e., making a folder, copying a .gpl file, setting up the JSON, etc. then adding or installing the extension.

I would recommend the first method since you may download dozens of palettes from the web (like from Lospec) not bundled like in the second format.