Parts of animation disappearing when sharing as gif

I’m new here (just got aseprite a few days ago) but this problem is just baffling me. I made a small animation of a mouse and saved it as a gif file to upload to giphy. It works completely fine up until I try to send the gif to anyone, at which point parts of the gif disappear. I did get a pop-up when exporting and saving as a gif that gif files don’t support layers but the parts that are disappearing and the parts that aren’t are on the same layer. Even so, I merged all the layers and tried again but nothing changed. I’m new to animation in general so this could easily be a problem with giphy or iPhone or a mistake on my part that I just don’t know about. Any help or info is appreciated. (Idk if this makes a difference but it worked while sending on discord)

Also just found out since I’m new, I can’t upload more than one thing in a post so uh
this is the way it DOES look when sent (there’s supposed to be a purple dress and pink ears on the mouse which is what is disappearing)

It’s probably a problem with the colours being too similar, happens a lot with gif, you need to make sure the contrast between the colours are significant enough to not be rendered transparent. I suggest changing the dress colour, or the background colour.

I changed the background to a light blue and the ears and dress to darker purples and pink and now when I send it to people, it either does the same thing (getting rid of the dress and ears) or it sends as a still image. It was sent correctly once but I didn’t do anything differently that time :confused:

Upload the .ase file somewhere, and throw us up a link. I’ll have a look at it.

is there transparency in the colors? they have to be fully opaque to be rendered in gif usually. Or glitchy stuff happens. Not sure why it doesn’t work as @Vee said upload the .ase and maybe we can help better.